WordPress.org

Forums

MySQL version... WordPress 2.2 (6 posts)

  1. desmondo
    Member
    Posted 7 years ago #

    Hi all,

    I had WordPress running fine on my local server, but when I uploaded it and put the database content in, it was coming up with Errors. I thought I would just delete all the tables and start again with a new installation, but when I went to install, I got this:

    ERROR: WordPress 2.2 requires MySQL 4.0.0 or higher

    I have checked in phpMyAdmin on the new host, I have the following information:

    MySQL Version:
    # Server version: 3.23.58-log
    # Protocol version: 10
    # MySQL client version: 4.1.12
    # phpMyAdmin - 2.10.1

    My question is, does WordPress require mySQL version 4.0.0 or higher for the client side or server version? My guess would be server version, as it is generating errors.

    Can someone point me in the direction of a page that gives detailed information of the requirements for WordPress 2.2 relating to client and server version of mysql?

  2. whooami
    Member
    Posted 7 years ago #

    the client stuff is of no consequence.

    The codex (its linked at the top of every page on this domain --> see "Docs" link) provides all of that information and much more.

    http://codex.wordpress.org/Before_You_Install

    See the second paragraph.

  3. desmondo
    Member
    Posted 7 years ago #

    Thanks for your prompt reply.

    Just to clarify...

    >> the client stuff is of no consequence.
    I take it that means I don't need to worry about it. Does that mean that the host I'm using has the correct version of mySQL - being that the Client version is 4.1.12?

    If that is the case, any idea why it would be giving me these errors? I have found this page with the requirements, but it doesn't speak of version 2.2
    http://codex.wordpress.org/Hosting_WordPress

    Is there a page available that speaks about version 2.2?

    Cheers

  4. whooami
    Member
    Posted 7 years ago #

    It's the server that is important. and 3.23.58 isnt going to do it.

  5. desmondo
    Member
    Posted 7 years ago #

    Sorry, I just realised my error in the last post...

    It's the server stuff that's important, gotchya, thanks for your help.

  6. desmondo
    Member
    Posted 7 years ago #

    Just one more question regarding this, can you "downgrade" wordpress from 2.2 to 2.0? Or do I have to re-install and start again?

    Cheers

Topic Closed

This topic has been closed to new replies.

About this Topic