Support » How-To and Troubleshooting » [Resolved] MySql problem?

[Resolved] MySql problem?

  • Hello,

    I’ve been using the wordpress for 3 months and everything has worked fine until now… Now, it seems that it overloads my server with MySql queries from time to time and the site loads up very slowly or not at all.

    My WordPress version is 1.5.2

    Does anybody know where the problem might be?

    Thank you!

Viewing 15 replies - 1 through 15 (of 20 total)
  • A link to your site would help.
    Has your host emailed you at all ?
    What plugins do you have running ?
    Who is your host ?

    Link: http://www.purebeautyblog.com/ NSFW

    I have my own servers, never had problems with sites… even blog was running smoothly without problems until recently…

    Active plugins: page navigation, pools, RSS fetched link list…

    There are currently 932 posts and 35 comments, contained within 13 categories.

    A few days ago it had between 12-13k visitors a day, not because of the problems it went to 10k daily 🙁

    You seem to be using the plugin that generates the 1,2,3,4,5 etc at the bottom of the page. Try disabling that – it has been reported to slow things down.
    I added the NSFW above.

    what does NSFW mean? ok, I will try to disable that! At the moment, the server is also extremely slow, so we should find out if that helps soon!

    Disabling it right now…

    “what does NSFW means?”

    Not safe for work.

    When I look at the report (SHOW PROCESS LIST) it seems that the blog sends too many MySql queries to the server and it causes the slowdown…

    [Moderated – code removed. We can’t understand it]

    I did reboot my server now and MySql was clean again… however, after a while another MySql query appeared and didn’t kill itself… just the same as above… so it seems that some queries don’t kill themselves and stay there and once there are too many (maybe they reach a limit), there is no more space for new queries and server slows down…


    mysql> status
    mysql Ver 14.7 Distrib 4.1.8a, for pc-linux-gnu (i686)

    Connection id: 2239
    Current database:
    Current user: xtoplist@localhost
    SSL: Not in use
    Current pager: stdout
    Using outfile: ”
    Using delimiter: ;
    Server version: 4.1.8a
    Protocol version: 10
    Connection: Localhost via UNIX socket
    Server characterset: latin1
    Db characterset: latin1
    Client characterset: latin1
    Conn. characterset: latin1
    UNIX socket: /tmp/mysql.sock
    Uptime: 31 min 58 sec

    Threads: 171 Questions: 85729 Slow queries: 1897 Opens: 151 Flush tables: 1 Open tables: 140 Queries per second avg: 44.697

    Please list all your plugins.
    When was it all last known to be good and what did you do since ?

    I posted two posts, it was still OK, then I tried to browse categories, it seemed to work… then I tried to search for certain KW’s and here the problem was… anyway, it’s not just searching because last time I searched for something with no troubles…

    here is the PROCESS LIST after it happened… now, it’s jammed!

    [Moderated – code removed. We can’t understand it]

    Please list all your plugins.

    Active plugins: pools, RSS fetched link list…

    and I was also using page navigation, but it think that the problem wasn’t in page navigation… now, page navigation is disabled!

    The … implies there are more ?

    What is this ‘pools’ ?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] MySql problem?’ is closed to new replies.