The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

MySql error when posting (7 posts)

  1. asfodel
    Posted 7 years ago #

    My blog has started displaying a MySql error whenever I make a post. When I click "publish" this is what it reads:

    Warning: mysql_affected_rows() [function.mysql-affected-rows]: A link to the server could not be established in /home/asfodel/public_html/wp-includes/wp-db.php on line 183
    Warning: Cannot modify header information - headers already sent by (output started at /home/asfodel/public_html/wp-includes/wp-db.php:183) in /home/asfodel/public_html/wp-includes/pluggable.php on line 275

    The post still publishes and appears on the site as normal.

    Can anyone tel me where can I look for the error in order to correct it? Or should I just not worry about it???

  2. tyler1234
    Posted 7 years ago #

    Mine does a similar thing, though my host (bluehost) brings down my site with a CPU overload message. Very annoying! Please help!

    Here is the snippet from the mysql_slow_queries folder:

    # Tue Nov  4 07:09:18 2008
    # Query_time: 60  Lock_time: 0  Rows_sent: 1096  Rows_examined: 3441
    use REDACTED_wp;
    SELECT <code>ID</code>, <code>post_author</code>, <code>post_date</code>, <code>post_date_gmt</code>, <code>post_status</code>, <code>post_name</code>, <code>post_modified</code>, <code>post_modified_gmt</code>, <code>post_parent</code>, <code>post_type</code>  FROM <code>wp_posts</code> WHERE ((post_status = 'publish' AND post_date_gmt <= '2008-11-04 14:08:59') OR  post_status='static' )  AND post_password='' ORDER BY post_modified DESC
  3. asfodel
    Posted 7 years ago #

    What my error message seems to be saying is that wp-includes/wp-db.php and wp-includes/pluggable.php have the same command and are interfering with each other? But I have never changed either of those flies.

    Since I recently edited my header and this issue seems to be related to the header, could I somehow have messed something up in the header.php or in the css related to the header (both of which I altered)?

    I recently corrected all the validation errors on my site and it now validates, so I don't think there should be any major errors in my code.

  4. BernardBorealis
    Posted 7 years ago #

  5. asfodel
    Posted 7 years ago #

    Thank you!

  6. asfodel
    Posted 7 years ago #

    I haven't bee able to fix the problem. I tried the suggestion of holding down the delete key for 15 seconds and then retyping the bracket, but that didn't work.

    I don't have a copy of the affected file (wp-db) because I installed wordpress via Fantastico and my most recent backup is from after the problem occurred.

    Is there anywhere I can find a copy of wp-db? My installation is 2.1 (yes, I know I should upgrade...)

  7. asfodel
    Posted 7 years ago #

    Since pluggable.php was causing the problem, I tried deactivating the plugins, and then reactivating one at a time. I found that the Google XML Sitemaps plugin was causing the problem. I guess I can live without a Google sitemap. Is there any fix for this?

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.