Support » Plugin: MyCurator Content Curation » MySQL error when activating the plugin

  • Resolved Kasutan

    (@kasutan)


    Hello,

    your plugin looks great and I really look forward to using it.
    At the moment though, I can’t create any topic.

    I checked my server logs and found an error message recorded when I first activated the plugin.
    If I understand correctly, the plugin tried to create a table called wp_topic, and received this message “Index column size too large. The maximum column size is 767 bytes.” The wp_topic table was not created.
    I tried running the same request again manually and got the same message.
    Is there a modified request that I could run in order to create the table?
    I’m using PHP7 and MySQL 5.6.
    Thank you for your help,

    Kasutan
    ****************

    Here is the original request :
    CREATE TABLE wp_topic (
    topic_id int(11) NOT NULL AUTO_INCREMENT,
    topic_name varchar(200) NOT NULL,
    topic_slug varchar(200) NOT NULL,
    topic_status varchar(20) NOT NULL,
    topic_type varchar(20) NOT NULL,
    topic_search_1 text,
    topic_search_2 text,
    topic_exclude text,
    topic_sources longtext,
    topic_aidbfc longtext,
    topic_aidbcat longtext,
    topic_skip_domains longtext,
    topic_min_length int(11),
    topic_cat int(11),
    topic_tag int(11),
    topic_tag_search2 char(1),
    topic_options text,
    topic_last_run DATETIME,
    PRIMARY KEY (topic_id),
    KEY topic_name (topic_name)

    ) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_520_ci

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author mtilly

    (@mtilly)

    It looks like our index got too big for some installations with a recent change to MyCurator. If you can run the request manually, just change the length of the topic_name field to (190) and it should work. We’ll add this change to our next update.

    • This reply was modified 1 year, 11 months ago by  mtilly.

    Thank you for answering so quickly, I certainly did not expect an answer during the weekend!

    I was able to run the modified query. The wp_topic table now exists, and I can create a topic and connect this topic to sources.

    According to other errors in the server logs, another table called wp_postsread appears to be missing. Would you kindly provide the SQL request for creating this table manually as well? This is not urgent.

    Thank you

    Plugin Author mtilly

    (@mtilly)

    The following should work, please reply if it does, or doesn’t. Thanks

    CREATE TABLE wp_postsread (
    pr_id int(11) NOT NULL AUTO_INCREMENT,
    pr_url varchar(1000) NOT NULL,
    pr_date DATETIME NOT NULL,
    pr_topics varchar(500),
    pr_page_content longtext,
    PRIMARY KEY (pr_id),
    KEY pr_url (pr_url(190)))

    Hello,

    the SQL request worked, thank you.
    I’ll keep an eye on the logs for other issues.

    Kasutan

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘MySQL error when activating the plugin’ is closed to new replies.