MySQL error (): 9 in several places (3 posts)

  1. Anonymous
    Posted 7 years ago #

    Getting the following error in several places including main content area and sidebar. (www.literacysolutions.com.au/blog/)

    Warning: mysql_error(): 9 is not a valid MySQL-Link resource in /home/li/lit/literacysolutions.com.au/public/www/blog/wp-includes/wp-db.php on line 282

    When logged into the admin area this error disappears from the content area but not the sidebar. When I log out of admin, it appears before each H1 in the main content area.

    Appreciate any thoughts about what the problem may be here.


  2. Michael Pratt
    Posted 7 years ago #

    I am having the same the same problem and can not figure out why.

    I am not understanding what it is telling me.

    The difference with mine is it says Warning: mysql_error(): 8.

    Any help at least pointing me in the right direction would be VERY helpful.

    Thank you,

  3. Michael Pratt
    Posted 7 years ago #


    I don't know why.

    I THINK I KNOW HOW. What I did was change hosting providers and this started. I basically zipped up my whole subdomain on the old server and unzipped it on it's own domain on the new server.

    In that process I had DE-activated my Sitemap pluggin.

    Tonight I got my site - http://racingnewsdigest.com - all corrected (links and things to reflect having it's own domain, database...ect).

    After that I reactivated the Sitemap pluggin even though I knew I was getting this error.

    That fixed my problem.

    PLEASE - If someone can explain this to me....I am all ears.

    It seams like I have had other problems with other sites with that pluggin deactived. I could be wrong.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.