[resolved] MyLinks2 causing problems with redirect URLs (5 posts)

  1. mlautens
    Posted 3 years ago #

    After the last update, any pages that use a ?=redirect in the URL redirected to a blank page and didn't function.

    For example, I could not logout. The logout function redirected to a page containing the logout code and it was simply a blank white screen. I never actually logged out. If I changed the settings on a plugin, the URL that brought me back to the settings page uses a redirect in it. That would also be a blank white screen (although the settings changes were actually made).

    I disabled all my plugins and the problem went away. I enabled them all again and the problem came back. So it's a plugin issue, no? I disabled them all again and started turning them back on one at a time. When I activated MyLinks2, there was an error message at the top of my screen about "unexpected characters" and I should contact the plugin author for support or disable the plugin.

    So I disabled it. Everything is running fine, now. I hope this is of some help to you. I wish I had a more precise description of what is broken, but I'll be happy to answer any questions (if I can).


  2. lecyril
    Posted 3 years ago #

    I also had an issue after upgrading to 4.6. Although I did not get the white page of death, I also could not log out without mylinks causing an error.
    You can try what solved my problem: open mylinks.php in a text editor, and remove the two blank lines at the end of the file, then reupload the modified file (remember to keep a copy of the unmodified file just in case...)

    This solved my issue, I hope the same for you!


  3. ejhonda
    Posted 3 years ago #

    Same issue with 4.6. We discovered we could not log into WP Admin page after the upgrade. Finally narrowed it down to MyLinks2 plugin being the culprit. Removed the 2 blank lines at the end of the mylinks.php file as suggested, and problem was solved. Thanks for the info Cyril.

  4. lecyril
    Posted 3 years ago #

    Glad this helped :-)

  5. 2020media
    Plugin Author

    Posted 3 years ago #

    We have corrected the error in the mylinks.php file. Sorry abot that - it didn't cause any problems when we were testing, but clearly it was a bug.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.