Support » Fixing WordPress » ‘mydomain’ didn’t send any data. ERR_EMPTY_RESPONSE

  • Hi

    I have 3 installs of WordPress on a friend’s hosting (I don’t have access to the hosting cpanel). One is a WP 4.9.? and two of them are the latest I assume as I installed them manually a month ago by grabbing the latest copy from WP website and uploading it via ftp. Everything was working fine.

    Last week something happened and the admin panel broke on all three installations.
    Initially, it was a social media plugin on one of the websites that broke the website even for visitors. I removed all the plugins and it’s working fine for visitors but if you want to access /wp-admin
    you get:
    mydomain.com didn’t send any data.
    ERR_EMPTY_RESPONSE

    Surprisingly, if you want to access /wp-admin/themes.php or widgets.php it is fine. It lets you in the dashboard and you can add/edit content. The only pages that throw this error is if you click on:
    Plugins
    Dashboard

    The rest of the admin menu works fine.

    The fact that it is happening on all 3 installations suggests that it is not necessarily with WordPress but could you advise me what it could be.

    I have created a page.php to display PHP version in a browser and it’s
    5.4.13

    Please advise.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Sam

    (@soumendra)

    Hello @portia79,

    Hope you are doing good today.

    ERR_EMPTY_RESPONSE usually occurs either from your computer or from the web server.

    Please follow this methods to see if that helps for troubleshooting the issue:

    1) Check your network connection/ check the site on another network

    2) Clear browsing data

    3) Reset network settings

    4) Update drivers

    5) Test with another browser/ test with another computer

    Hope that helps.

    Thank you.

    Hi there,

    Thank you for your reply. I’ve cleared the cache, browsing data it’s stil the same. I don’t think it’s to do with my network or browser. Other people also reported the same. Also I don’t have any problems with wordpress dashboards on installation on another hosting.

    I just tried to do another installation. The same thing happens. It starts ok when you put the db credentials and then the next page throws the same error.

    Sam

    (@soumendra)

    Hello,

    Can you atlist check on another computer with some other internet connection to see if that helps?

    Mostly, the ERR_EMPTY_RESPONSE occurs on chrome browser due to the issue with the internet or some caching issue which is confirmed by google also.

    Please read the article here:
    https://support.google.com/chrome/answer/95669?vid=0-175552448314-1493325043142&visit_id=1-636289218508828898-695176163&rd=1

    Also, please follow these stapes to see if that helps resolving the error:

    Open Command Prompt and run these commands one by one

    ipconfig /release
    ipconfig /all
    ipconfig /flushdns
    ipconfig /renew

    netsh int ip set dns
    netsh winsock reset

    Then restart your computer.

    Hope that helps.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘‘mydomain’ didn’t send any data. ERR_EMPTY_RESPONSE’ is closed to new replies.