Support » Fixing WordPress » My WP website shows “Fatal error” !

  • Resolved aziiiz

    (@aziiiz)


    Hey guys how are you are doing
    Today when i entered my website, this appears with white background” Fatal error: Class ‘WC_Payment_Gateway’ not found in /home4/aziz/serajj.com/wp-content/plugins/payfort/inc/main.php on line 4″
    I’m not sure whats the problem
    My hosting is with Hostgator, but they don’t have anything with it, because I have another website with the same hosting and it is working currently.

    Appreciate your solutions

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Keith

    (@keithdriscoll)

    The error message is telling us that the Payfort plugin is causing an error.

    Class ‘WC_Payment_Gateway’ not found

    This most likely indicates a programming error as it is not able to locate a piece of code. The plugin page indicates that this plugin has a small user base and has not been updated in a while. Maybe you can try and contact the developers in the plugins’s dedicated support page here:

    https://wordpress.org/support/plugin/payfort

    *after writing this reply, I see others are experiencing the same issue as per the plugins support page.

    That’s a problem with the Payfort plugin (as seen by ‘/plugins/payfort/’).

    Just as a first question, do you have WooCommerce installed and activated? That’s the first thing that you’d need to have. Apart from that I’d suggst using FTP of your hosting companies file manager to remove or delete that plugin to get your site back and running again.

    Keith

    (@keithdriscoll)

    You can disable the plugin via FTP or your web hosting control panel simply by renaming the payfort folder within the wp-content/plugins folder to something else.

    Thanks a lot guys
    you are awesome
    I went to C panel and deleted Payfort folder and the website returned
    Thanks Keith

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘My WP website shows “Fatal error” !’ is closed to new replies.