WordPress.org

Forums

My wordpress died. First time. What to do?!_!_!_!_! (16 posts)

  1. aguitta
    Member
    Posted 6 years ago #

    It seems my wordpress died today, open the site in my browser. I went to se the error log in my hosting company, and aparently I can view and look at the files there. So its not really the hosts server, its and I get this:
    Error Log:
    [16218] EACCELERATOR: PHP crashed on opline 109 of (null)() at /home/achazo/public_html/wp-includes/theme.php:91

    About as many times as I hopelessly press the reset button, hoping its some kind of server fluke. But its not, other files in the server are working. What do I do...?
    Juanfra.

  2. aguitta
    Member
    Posted 6 years ago #

    Las message was written in panic. Please excuse the babbling, but really, if anyone can help me with this, it woudl be fantastic. I want to know of a trouble shooting procedure to revert my website to an earlier back up, but I am clueless as to what to do.
    Aguitta.

  3. TheSooFoo
    Member
    Posted 6 years ago #

    EACCELERATOR, is that a plugin? If so delete its directory. Or, if you can get into the admin uninstall it.

    Normal troubleshooting steps are like this:
    Did you install a plugin recently? If so, uninstall it.
    Did you change any template code? If so, undo that.
    etc.

  4. aguitta
    Member
    Posted 6 years ago #

    Thanks, I have no access to admin, I dont think that EACCELERATOR is a pluggin. But I recently enabled a pluggin called rolemaneger and enabled it so registered people put in full html.
    That was yesterday and it worked fine. but today I simply cant acces wordpress at all.

  5. TheSooFoo
    Member
    Posted 6 years ago #

    Can you get FTP access to your files, or access through your hosts control panel? You should be able to. If so, go into your wordpress plugin directory and delete the folders associated with the bad/evil plugins.

    That, in effect, uninstalls the plugin. Then see if things are happy again. If not, maybe delete some more plugins you think are bad. The thing is with deleting the plugin folders, if you want to have that plugin back you just reinstall it.

  6. aguitta
    Member
    Posted 6 years ago #

    Ok, im going to try that.
    Thanks. Ill keep you posted. And thank you again. your sopport is really godsent.
    -aguitta.

  7. aguitta
    Member
    Posted 6 years ago #

    No succes...
    Ive erased the last pluggin I installed (Role Manager). and it really did not affect the problem. Do you think some one could of added malicious html?... some how that could of made the page unaccesiible?

  8. aguitta
    Member
    Posted 6 years ago #

    Is there a wordpress log you can acces through ftp interface?

  9. whooami
    Member
    Posted 6 years ago #

    eaccelerator is not a plugin for wordpress. its an addon for PHP that is used for caching.

    Do you think some one could of added malicious html?... some how that could of made the page unaccesiible?

    No. read above.

  10. aguitta
    Member
    Posted 6 years ago #

    So, what do you recomend doing?

  11. aguitta
    Member
    Posted 6 years ago #

    This is the site, http://www.masgol.com/ if it helps.

  12. whooami
    Member
    Posted 6 years ago #

    I recommend following a common sense process to determine the cause of the problem. You disable plugins. Refresh the page, and I mean a HARD refresh to see if that solves it.

    If it doesnt, I recommend changing your theme, and seeing if that doesnt solve it.

    You can also try contacting your host and asking then to disable eaccelerator for you.

  13. aguitta
    Member
    Posted 6 years ago #

    Im contacting the Hosting company. And I will delete pluggin directories methodically. Their support lines are jammed, that could be an answer on itself.
    Thank you again,
    Aguitta.

  14. aguitta
    Member
    Posted 6 years ago #

    Well, no luck yet.

  15. whooami
    Member
    Posted 6 years ago #

    we dont need minute by minute updates.

  16. aguitta
    Member
    Posted 6 years ago #

    A friend pitched in, Alejandro Vítola, ( And once again rescued the site). The problem was solved this way.
    Because there is no acces to wordpres admin panel, the next resort was to go to the hosting cpanel. There, review the error log and saw this error: [16218] EACCELERATOR: PHP crashed on opline 109 of (null)() at /home/achazo/public_html/wp-includes/theme.php:91

    eaccelerator is not a plugin for wordpress. its an addon for PHP that is used for caching.

    -Whooami

    So, the EACCELERATOR had to be blocked off the site: This was done by:

    php_flag eaccelerator.enable 0
    php_flag eaccelerator.optimizer 0

    and adding that to the .htaccess file located in the root directory. Alejandro recomends we wait and see what livingdot.com have to say about the eeaccelerator.
    So Thank you Alejandro, Whooami, Thesoofoo. Website is now operational, I´ll go and wash of the tension now. :).

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.