WordPress.org

Support

Support » How-To and Troubleshooting » My whole site is gone?

My whole site is gone?

  • I just tried to bring up my site and everything is gone. My domain came back with a default WP theme that just says hello world. All of my content is gone? Can anyone please help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Christine Rondeau

    @crondeau

    Volunteer Forum Moderator

    Sounds like something happened to your database. Have you contacted your host? Maybe there was an error with one of their server.

    Moderator Jan Dembowski

    @jdembowski

    Volunteer Mod. & Brute Squad

    Link please? And check your wp-config.php database settings to confirm that you are pointing to the right database.

    Edit: Doh! Second place! Again!

    Moderator Jan Dembowski

    @jdembowski

    Volunteer Mod. & Brute Squad

    Well, thanks to Google cache I can see what it used to look like.

    Just as Christine said, you may want to contact your host. It’s not that you have no database, it looks like you have the earliest version of your database there.

    thanks I’ll be contacting host gator

    Well I just spent 30 minutes on the phone with hostgator and I’m not up and running yet but promised to stay on it until it’s fixed. That tells me that they at least have a backup. I’ll just have to wait it out.

    It does indeed sound like your database is missing or at least the connection is messed up. I would suggest downloading a database-backup plugin, WP-DB-Backup works great and (if I remember right) can be set to automatically backup your data so you don’t have to worry about it!

    Search around, find one you like, and set it up! Imagine if you were running a large, complex database and you lost it all :S

    Hey thanks…Hostgator has a backup that they’re reloading for me. When it’s restored I’ll get that plugin.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘My whole site is gone?’ is closed to new replies.