Support » Plugin: WassUp Real Time Analytics » My whole site down because of fatal error

  • Resolved anarelle

    (@anarelle)


    I don’t remember which exact WP version I’m using, since I can’t even log in to my admin console to check it.
    After I asked my hosting to enable wordpress debug, I can see the following error:
    Fatal error: Call to a member function is_recording_active() on null in /[myhostingurl]/htdocs/wp-content/plugins/wassup/wassup.php on line 512

    How can I fix this? Like I said, my whole site is down and not even the admin console is available. Just pointing my browser to my site shows that error message.

    Thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor helened

    (@helened)

    You have to manually delete the wassup folder in the plugins directory on your WordPress host.

    If you have an ftp client software on your computer or in a browser add-on, you can use that.
    Otherwise you need to log into your WordPress host account, go to the Cpanel, click the File Manager, find your site name under ‘www’, ‘htdocs’, or ‘public_html’, go to wordpress/wp-content/plugins directory, select “wassup” folder and delete it.

    Good luck.

    Thread Starter anarelle

    (@anarelle)

    That did the trick. Thanks!!
    Although I’m curious as why that happened, to avoid it in the future.

    This is a great solution if you don’t want to use the plugin in anymore. But we still do. So I’ve renamed the directory for this plugin, but I need it to work. How can I troubleshoot this error?

    Plugin Contributor helened

    (@helened)

    jrockpress,

    We are currently testing a fix for this.

    If you are comfortable hacking plugin code, you can try do this fix yourself. Login to the ‘Cpanel’ on your web host, go to “File Manager”, open ‘wassup’ folder in ‘/wordpress/wp-content/plugins/’ directory, highlight ‘wassup.php’ module, and open it with the File Manager’s “Code Editor” option, then:

    • find lines #93-97:
      
      	}else{
      		//Load existing wassup wp_option settings, if any
      		$wassup_settings=get_option('wassup_settings');
      		if(count($wassup_settings)>1 && !empty($wassup_settings['wassup_version'])) $wassup_options=new wassupOptions;
      	}
      
    • replace the contents of the ‘else’ statement with this line:
      $wassup_options=new wassupOptions; so that the modified else statement looks like:

      
      	}else{
      		//Load existing wassup wp_option settings, if any
      		$wassup_options=new wassupOptions;
      	}
      
    • save and exit.

    Hopefully this will fix the error.

    This error did not show up in our tests (and still doesn’t), so it was unexpected. When Wassup resumes working, we would appreciate learning more about your WordPress setup so we can avoid this problem in the future. If you could post information about your host provider (Bluehost,GoDaddy,etc), the type of server that your site is on (Linux or Windows, shared or dedicated), the plugins that you have installed, and your WordPress active theme name, it would be of great help.
    Thanks.

    Didn’t work. When I went to activate the plugin, I got this:

    Parse error: syntax error, unexpected ‘else’ (T_ELSE) in /wp-content/plugins/wassup/wassup.php on line 97

    My host is HostGator, VPS, Linux, theme is a child of the Doover Theme (https://themeforest.net/item/doover-wordpress-theme/2279114).

    This site has TONS of plugins.
    BackupBuddy
    Disqus
    Google Analytics by MonsterInsights
    Google Analytics Suite
    Gravity Forms
    Gravity Forms User Registration Add-on
    iThemes Security
    iThemes Sync
    Taxonomy Images
    WooSidebars
    WP Engine Automated Migration
    Yoast SEO
    Youtube shortcode

    • This reply was modified 5 years, 1 month ago by James Huff.
    Plugin Contributor helened

    (@helened)

    Hi jrockpress,

    Thanks for the information. We can now test for conflicts or other issues in your setup.

    p.s. You should hide your home path directory when showing errors in this forum. Too many eyes are watching and someone could try access your server with this information.

    Ugghhh. Yes. Thanks. Do you know if can modify my post?

    Plugin Contributor helened

    (@helened)

    According to the forum docs, you can’t edit a post after 35 minutes has passed.

    I went ahead and added a ‘modlook’ tag to this thread to get the attention of a forum moderator about your post. Hopefully, he/she would be willing to delete the post (post-8299156) because it poses a risk to your site’s security. I’ve got the info I need to troubleshoot the problems with Wassup, so it’s not needed anymore.

    • This reply was modified 5 years, 1 month ago by helened. Reason: add modlook tag

    So the update worked for me! Thank you!

    We inherited this site, so I’m not really sure what this plugin does. It seems though, that any past data is lost. Is that correct?

    Hello,
    I am trying to figure out how to get help fixing a fatal error appearing on my site. It is:
    Fatal error: Call to undefined method WooCommerce::mfunc_wrapper() in /nfs/c04/h04/mnt/162832/domains/rajacoby.com/html/wp-content/themes/whitelight/header.php on line 96
    I am not a coder or designer and only have experience adding imagery to my site. I haven’t been able to figure out how to post a question in a forum so finally I am here and I apologize if it is the incorrect place to post a question but I have searched and searched and can’t find a way to start a new post.
    I’ve been told the issue on my site is with Whitelight which I believe is no longer in use by WordPress. But I’ve updated it and everything else that could be updated.
    Any suggestions for how to get my website back?
    Remember I am not a coder or experienced word press user. Someone else made my site and is no longer able to make changes or give support. If you can offer help, instructions that use as little coder lingo are ones I can follow, as in: “go to dashboard, go to editor, go to… scroll down to this… replace “x” with “y.”” Etc.
    Thank you.

    @rebecca94: Please do not post unrelated issues into old threads.

    Unfortunately, according to the support page for your theme, it appears that your current theme has been retired and there will likely not be any more support provided. You might consider finding a different theme.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘My whole site down because of fatal error’ is closed to new replies.