Support » Plugin: Beaver Builder - WordPress Page Builder » My website got crashed

  • Yesterday my website got crashed due to your new update.

    These were the errors:

    trim()expects parameter 1 to be string

    preg_match() expects parameter 2 to be string

    explode() expects parameter 2 to be string

    Kindly fix this bug ASAP.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Simon Prosser

    (@pross)

    Unfortunatly Vantam themes are not compatibale with version 2.6 and they refused to fix the issue or add support.

    Lucky for you though I did fix the issue late late night and we will release a fix later today with the following code added that stops the vantam fatal error.

    for now add this to your child theme functions.php

    add_action( 'after_setup_theme', function() {
    	add_filter( 'vamtam_less_vars', function( $vars ) {
    		if ( isset( $vars['beaver-global'] ) ) {
    			foreach( $vars['beaver-global'] as $k => $var ) {
    				if ( is_object( $var ) || is_array( $var ) ) {
    					unset( $vars['beaver-global'][$k] );
    				}
    			}
    		}
    		return $vars;
    	});
    });

    As always thanks for the review, its alway appreciated

    Plugin Contributor Jamie VanRaalte

    (@codente)

    We’re told that the VamTam team actually pushed an update for the BB compatible themes earlier today so you can give that a try and see if it resolves your issues with BB.

    If you’re not using VamTam theme or updating to the latest VamTam release does not solve it, then we’d love to help you solve this problem but we can’t help you here in a review. Please create a support thread here:
    https://wordpress.org/support/plugin/beaver-builder-lite-version/

    And we’d be glad to help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this review.