WordPress.org

Ready to get started?Download WordPress

Forums

My website and sharing Facebook links / like buttons (10 posts)

  1. itssomedudeguy
    Member
    Posted 8 months ago #

    This is my first post here and it's about a problem that has been bothering me for months! It seems more than half a year ago, Facebook stopped sharing any links from my blog site; Somedudeguy.com. Like buttons also don't work on it when it used to and anytime I use Facebook link debugger, all it does is spit back an error message; "Response code 206," "An internal error occurred while linting the URL."

    There does not seem to be much documentation on this error message and how to resolve it with a wordpress based website. Contacting Facebook on this issue is impossible, but I have tried to do things that has not solved the problem...

    -Disabled all plugins
    -Went to the default theme
    -Installed the Facebook open graph plugin
    -switched to a different webhost
    -Called up random Facebook phone numbers available online with no one willing to help me.
    -Uploaded a fresh install of WordPress to the webhost without any plugins and default theme, After writing a test blog post, problem still persists.

    What has worked

    I also own the domain Somedudeguy.ca. During my testing, when uploading a fresh wordpress install to the new webhost and point that domain to it, posting a test blog post to Facebook works! it just when conducting the same test with somedudeguy.com, I get that error and non of my test posts works on Facebook.... Whats going on??? Please help!

  2. Pioneer Valley Web Design
    Member
    Posted 8 months ago #

    Please enable Permalinks.

    But: first switch to default unedited theme, deactivate all plugins, force reset of Permalinks per above, then just run the Facebook debugger to see if initial error is cleared. Note: The debugger caches, so try again in 24hrs.

  3. itssomedudeguy
    Member
    Posted 8 months ago #

    Alright, I will get back to you on this in 24 hours...

  4. itssomedudeguy
    Member
    Posted 8 months ago #

    Alright so this is what I did....

    I just uploaded a fresh install of WordPress with a fresh database. Its on the default theme and I switched the Permalinks to Day and name. The result... Still having problems getting Facebook to see my blog site. Facebook debug is still spiting back the same errors at me. What other solutions should I try?

    [Moderator Note: No bumping. If it's that urgent, consider hiring someone instead.]

  5. esmi
    Forum Moderator
    Posted 8 months ago #

    Stop bumping!

  6. Pioneer Valley Web Design
    Member
    Posted 8 months ago #

    I just uploaded a fresh install of WordPress with a fresh database. Its on the default theme and I switched the Permalinks to Day and name.

    The reason we ask folks to do this is to decide if it's an installation, theme, or plugin issue (or combination of). You did not mention removing all plugins. Assuming you did a full clean install, then the issue is with Facebook or your web host. If there was an issue with WP root installs, this forum would be flooded with them (and it is not).

    https://developers.facebook.com/support/

    As for the host, discuss being behind a proxy with them.

  7. itssomedudeguy
    Member
    Posted 8 months ago #

    What I still don't understand is how my tests has concluded that there is nothing wrong with the web server and WordPress when everything is sent though my 2nd domain (Somedudeguy.ca). Yet when I conduct the same test under the same conditions with my .com, all the errors pop up and preventing my links to be shared on Facebook.

    Is Facebook blocking my .com for some reason? Is this the symptoms of a blacklisted domain on Facebook?

  8. Pioneer Valley Web Design
    Member
    Posted 8 months ago #

    Is Facebook blocking my .com for some reason? Is this the symptoms of a blacklisted domain on Facebook?

    We cannot address why a third party, in this case Facebook does things. The one to ask is Facebook.

  9. Pioneer Valley Web Design
    Member
    Posted 8 months ago #

  10. itssomedudeguy
    Member
    Posted 8 months ago #

    I have fixed somedudeguy.ca for you to test it. I just had to make a new folder and database for it. You should now have the ability to test both websites with Facebook to see where (if any) the problems are thats causing me this huge frustration.

Reply

You must log in to post.

About this Topic