WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] My theme is getting all messed up with firefox?

[Resolved] My theme is getting all messed up with firefox?

  • I am using the aggregate theme by elegant themes. I am just beginning to set up a website/blog and the homepage is all messed up. My logo is missing and everything is jumbled and somewhat pushed to the left. I use safari and have only tried firefox to see what it looked like on other platforms.

    My website: http://www.moreapplesaday.com

    Any assistance would be greatly appreciated.

    Thanks,

    Pete

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi moreapplesaday,

    The site looks off in Firefox, but it looks a little better in Internet Explorer.

    The reason I believe is that you are calling images correctly. In Firefox, they image placeholder is not shown, but in Internet Explorer you are seeing a red X that still takes up a specific width and height.

    You have several images that you’re calling with this URL:
    http://moreapplesaday.com/
    … this should instead look something more like:
    http://moreapplesaday.com/wp-content/uploads/2011/10/logo.png

    I used that image above as an example because it looks correct, however when I view:
    http://moreapplesaday.com/wp-content/uploads/2011/10/logo.png
    … I get an error:
    The image “http://moreapplesaday.com/wp-content/uploads/2011/10/logo.png” cannot be displayed, because it contains errors.

    What software did you use to create that logo?

    Hey imh_brad,

    I used photoshop cs5 to create the logo.

    I just removed my logo for a moment and let the generic aggregate one replace it. This logo shows up fine on firefox, but everything is still shifted to the left on the homepage. I am not sure what is wrong with my logo.

    Does anyone know how I can fix my logo and whatever else is causing problems with my website on other platforms other than safari?

    Hi moreapplesaday,

    In regard to the image not showing correctly, I searched the web and there were quite a few others having a similar issue. Unfortunately the only recommendations I noticed were to resave the image again and then upload again.

    You may also want to try another image editor to save the image.

    I fixed my theme. Does anyone have any idea how I can fix my homepage from shifting towards the left?

    Thanks for the help so far brad, much appreciated.

    Hi moreapplesaday,

    I fixed my theme. Does anyone have any idea how I can fix my homepage from shifting towards the left?

    Your theme is shifting to the left because you have images that are not loading. Once your images load, they will load and push the other content to the right, making everything (hopefully) look correct.

    <img src="" alt='Holy Water' width='958' height='340' />
    <img src="" alt='Running Shoes & My Feet' width='958' height='340' />

    Looking at the two images above, the src value is missing. You’ll want to make sure you fill that in with the path to your images. I’m not familiar with the tools you’re using however, so unfortunately I’m at a loss on exactly how to do that.

    I hope this at least helps point you in the right direction.

    It seems to be something with the category I am featuring in the homepage slider. The slider will not work when I use blog as the featured category. It will not allow me use any categories that have sub-categories, is there any way around this?

    I re-uploaded my posts and rearranged the slider to one category and it still shifts to the left if more than one post is featured in the slider.

    Hi moreapplesaday,

    I don’t feel like I’m helping at all, so I’ll make this my last post and let someone else who knows more about this specific theme chime in.

    I did find this faq page:
    http://www.elegantthemes.com/troubleshooting.html

    … that states:

    2. I created a Featured Articles category, but the posts aren’t showing up on my homepage under the Featured Articles section. What did I do wrong?

    Usually this means that you have misspelled the category, added an extra white space to the category, or did not capitalize the first letters of each word. Your category must be called “Featured Articles” exactly – it is case-sensitive. Try deleting the category and creating it again, making sure that you spell it correctly. You should also make sure that the category slug of the Featured Articles category is set to “featured-articles.” The above only applies to older versions of the themes, in which no option to choose your Featured Articles category is available.

    I hope this helps. Let me know if I can help any further.

    esmi

    @esmi

    Forum Moderator

    As this is a commercial theme, we cannot really help. You need to seek support from the theme vendors.
    Elegant Themes Support: http://www.elegantthemes.com/forum/

    Thanks imh_brad! I added a few dummy pictures to see if it would help with the glider and it solved the problems. Thanks again!

    Thanks esmi. I am new to this so thanks for the good pointer.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] My theme is getting all messed up with firefox?’ is closed to new replies.
Skip to toolbar