Support » Networking WordPress » 'My Sites' list broken

  • Resolved rollerbob


    I recently upgraded to 3.5.1, as well as upgraded multisite plugins and something odd has happened to the network admin.

    Let’s say i’m logged in as a Super Admin on site titled ‘Foo bar’. When I hover over ‘My Sites’ in the admin bar, each if the site titles in the drop-down has been replaced by ‘Foo bar’. Likewise, when clicking on My Sites, I just see the current site ‘Foo bar’ listed repeatedly on the page, instead of the list of sites titles on the network.

    If I go to /wp-admin/network/sites.php and hover over ‘Dashboard’ next to each site title, I see that the URL goes to the /wp-admin instead of /foobar/admin.

    There are only 2 plugins that are network activated (the others are activated on the sub-sites). I’ve tried disabling both of these to no effect.

    Can anyone explain what might be happening here?

Viewing 10 replies - 1 through 10 (of 10 total)
  • I’m experiencing this same exact issue as well. Rather than displaying all my sites on the network, the list only shows the site I’m currently on repeated as many times in the list as the amount of sites in my network.

    When I click on one of the links in the list I’m also just sent to the dashboard of the site.

    Betcha you haven’t upgraded W3TC yet.

    lol! well, I did actually upgrade it, but I haven’t actually sat down to see if the changes in the new version affect my install.

    Any particulars I should be looking for?

    Oh… right. Just started fiddling with it and all my awesome config went with the upgrade (yay…). On the upside it DID solve the issue I had here!!!

    Thanks, Mika! You’ve saved my butt twice this year and we’re not even halfway through the year!

    Somehow I just know my head will explode anyways when Buddypress 1.7 finally comes out. That’s… I’ll just be happy for this moment.

    Betcha you haven’t upgraded W3TC yet.

    W3TC is at the latest version That’s said, the plugin page is reporting that it’s broken for 3.5.1. Still not sure how this can be causing the problem as the plugin isn’t network activated.

    Alright, well this is the info I gathered and where I’m headed:

    The new update to W3TC basically re-writes a lot of stuff and therefore it isn’t just a simple upgrade to the previous version.

    I’m running multisite on WP 3.5.1 and believe me (ask Mika) I was getting really good results, but then I upgraded to and I realized the plugin switched itself from being activated individually on each site to being network activated (i.e. only one config could be set up and I couldn’t activate it just per site in the network).

    After I saved the configuration file like the plugin asked me, the issue with the repeated sites in the “My Sites” list went away.

    According to this thread the issue is related to the plugin changes and it’s advised you save your current configuration (if you didn’t already before you updated) and then uninstall w3tc altogether and install a fresh setup of the new version.

    It’s a pain, sure, but it’s not all the w3tc dev’s fault. We just have to be more careful and maybe not be so hasty in upgrading in the future.

    Also, for some reason when I upgraded w3tc all my config got lost, so do check that it’s even there to avoid any confusion later.

    I’m in the process of uninstalling the plugin (using a guide like this) by deleting a bunch of stuff the plugin creates in your wp-content folder.

    W3TC is at the latest version That’s said, the plugin page is reporting that it’s broken for 3.5.1. Still not sure how this can be causing the problem as the plugin isn’t network activated.

    Right, totally uninstall W3TC. That means all the cache folders etc gotta go. Then reinstall and it’ll work. I don’t know why this happened but that’s what did it for most of us.

    Thanks Ipstenu. Uninstalling W3TC and deleting db.php and object-cache.php from the WP root folder solved it for me.

    Whew! That one had me baffled.
    Thank you so much! I had W3TC Installed, but not activated – so I didn’t even think that would be the issue.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘'My Sites' list broken’ is closed to new replies.