Support » Plugin: AMP for WP - Accelerated Mobile Pages » My site’s Desktop Version is super fast but AMP is super slow.What to do?

Viewing 15 replies - 1 through 15 (of 24 total)
  • First of all that cloudflare option has nothing to do with it. This option is when they see another link coming to your site from one of their customers – read their blog about what it actually does.

    The second thing here is that your AMP home page is not representative of your canonical page – google is less likely to look favorably upon it in terms of the mobile search results that they show. You are probably better off using the tools provided to make your own AMP home page by hand or not use it for a home page which is only a list of blog articles.

    When I do a page speed test, it is unable to properly analyse your AMP version. It says speed unavailable. Personally I prefer to use this tool as it is much more comprehensive

    https://gtmetrix.com/reports/www.hospitality-school.com/hkI5zdjg

    And you will see that your page is very good. The thing to remember here is that google caches pages so many of these speed tests don’t mean much. Personally, I wouldn’t use AMP for your home page but use it for your posts only.

    • This reply was modified 1 year, 5 months ago by  frenchomatic.
    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Hi @hoteliertanji

    That’s extremely strange. It shouldn’t be this low considering when I use the website, it’s super fast in mobile.

    There’s probably some misconfiguration happening when I add a slash at the end, the same website now goes from 16 to 59. See: https://developers.google.com/speed/pagespeed/insights/?url=http%3A%2F%2Fwww.hospitality-school.com%2Famp%2F

    Did you made any specific changes to remove the slash from the end?

    Don’t worry, I will help you until we have great performance going on.

    Also, can you try to switch to design one?

    Hi @ahmedkaludi

    Just switched to design one. Should I enable this option “Make endpoint ?amp=1” under Custom Post Type?

    I don’t understand technical things deeply but haven’t done anything to remove / at last, as far as I at least know.

    2 days back I tried Fetch as Google without / at last and saw this error.

    https://i.imgur.com/T5xXnTR.png

    You may get some idea from this screenshot. But just today I tried again without / and everything seems ok now.

    IS THERE ANYWAY TO MAKE WITH / VERSION PERMANENT? ALSO AMP VERSION SHOULD BE SUPER FAST CONSIDERING THAT DESKTOP VERSION IS FAST. HOW TO FIX LOADING ISSUES?

    https://gtmetrix.com/reports/www.hospitality-school.com/9elL4UoD

    Very fast. Very strange google pagespeed insights says it can’t load the site properly. I think something is going on with a W3 total cache setting. You may want to exclude AMP pages in W3 total cache or try and find the setting which is doing it (probably minimization of some sort).

    Plugin Author Mohammed Kaludi

    (@mohammed_kaludi)

    Hi @hoteliertanji

    No, ?amp=1 won’t do the trick in this case.

    I would recommend you to contact our team on https://ampforwp.com/support/ – They will personally look into this one for you.

    Are you using any method or ways to remove the “/” from the URL?

    I excluded amp pages from caching and minification and it solved my issues with W3TC and Amp for Wp

    • This reply was modified 1 year, 5 months ago by  oceanmedia.
    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Hi @oceanmedia

    I’m glad to know that.

    Thanks!

    @ahmedkaludi,

    Would you please have a look at Ticket #2839. Your support staff really haven’t understood my problem and completely ignored. Still my site is getting very very low rank on pagespeed and takes long long time to get loaded fully.

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Hi @hoteliertanji

    I’m extremely sorry for this, I will personally look into your issue and make sure that this doesn’t happen the next time. I will be answering your email personally.

    I am getting same problem with amp plugin only 49 score. https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Fwww.raghwendra.com%2Fblog%2F&tab=mobile

    Please help! Thank you.

    Plugin Contributor ampforwp

    (@ampforwp)

    Hello Wdraghwendra,

    You are welcome.

    Thank you for writing to us.

    With regards to your query, I suppose that you are not using caching, try to use it and also would like to inform you that Use Swift Theme and check the Optimization.

    asepiiiii

    (@asepiiiii)

    I got a score of 10 on my cellphone when using an amp even though on the desktop I got a score of 79 on pagespeed, is this because I use the free amp?

    Plugin Contributor ampforwp

    (@ampforwp)

    Hi Asepiiiii,

    It’s not because of you using a free AMP, it seems to be a strange issue so could you send me the URL so that UI can check it for you and may I know where have you been checking for this?

    Hi

    I’m having the same issue, i use hummingbird plugin.

    Hi @mzidani,

    What the exact issue you are facing? And can you share the URL?

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.