WordPress.org

Forums

[resolved] My site was under construct under dev. and now that is what is showing up (7 posts)

  1. dcaspall
    Member
    Posted 1 year ago #

    I had a site under construction at dev.surroundingsbydebi.com

    Now that is the way it appears on my wordpress even though I have now gone live as surroundingsbydebi.com. Jetpack is not working, Comments don't work. Help!

  2. Viktor Nagornyy
    Member
    Posted 1 year ago #

    Hi Debi, did you get this sorted out? I did not see issues you mentioned, and comments appear to work now. Although I see menu is breaking to second line. Screenshot: http://i.imgur.com/OzBtxs6.png

  3. dcaspall
    Member
    Posted 1 year ago #

    No I did not get the problem solved. I do not having a working comment section.

    This is the message I get on Jetpack

    Something has gotten mixed up in your Jetpack Connection! 

    IDENTITY_CRISIS:
    Your siteurl option is set up as http://surroundingsbydebi.com, but your WordPress.com connection lists it as http://dev.surroundingsbydebi.com!
    Your home option is set up as http://surroundingsbydebi.com, but your WordPress.com connection lists it as http://dev.surroundingsbydebi.com!

  4. dcaspall
    Member
    Posted 1 year ago #

    I host with Go Daddy and when it was under construction the url was dev.surroundingsbydebi.com. Once it went live it went to http://www.surroundingsbydebi.com but it did not change in wordpress. I have read on wordpress how to make the change but I am a newbie at this and am not sure how to change all of the CSS. I talked with Go Daddy and they suggested I don't change anything. If I don't use the jetpack comment area I then have a bunch of html under my comments section.

    I just want to get the wordpress url to read correctly so everything will link up. At this point I can't link to my Facebook page either. It all seems to stem from the broken link with jetpack.

  5. Viktor Nagornyy
    Member
    Posted 1 year ago #

    Hi. Try disconnecting Jetpack from your wordpress.com account and then re-connect it back, it should re-sync with new URLs.

    Jetpack still tries to connect to dev subdomain since that's the initial URL used to authorize the connection.

    Try that and let me know how it goes.

  6. dcaspall
    Member
    Posted 1 year ago #

    Thank you! Thank you! Thank you!

  7. Viktor Nagornyy
    Member
    Posted 1 year ago #

    Happy to help :) I love helping small business owners with their websites, and I took a look at your site. Here's a few things I wanted to add you should do to make sure you're getting the most out of WP:

    1. You need to install WordPress SEO by Yoast plugin, right now site is not optimized for SEO.

    2. You should sign up and add to your site Google Analytics, so you get detailed data on your traffic.. this is in addition to stats tracked by Jetpack.

    3. Your contact page does not work right now, so people can't contact you.

    4. You should disable Facebook icon in the top right corner since its empty.

    5. If you're using Godaddy's cpanel hosting, there's an option called "Optimize Website". If you click on it, select "Compress All" and save. This will speed up your website.

    Bonus: if you plan on getting business from this site, you might want to make contact link/button easily seen to help people get in touch with you.

    That should give you a better handle on wordpress :)

    Hope that helps,
    Viktor

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.