WordPress.org

Support

Support » How-To and Troubleshooting » My Site is running slow… any support appreciated

My Site is running slow… any support appreciated

  • This is the site I built, my wife’s coaching business.
    http://www.susanmillercoaching.com

    Installed on GoDaddy wordpress account (which I just upgraded to hoping it would speed it up)

    WP: 2.9
    Atahualpa Theme, upgraded

    All plugins upgraded…

    I minimized to only the plugins I need.

    I tried some of the cache plugins and no effect..

    The site still takes forever to load… any guidance or support, my skills are moderate and I can make code changes if required with good step by step instructions.

    Thank You
    Philip Miller Madeley

Viewing 7 replies - 1 through 7 (of 7 total)
  • I need a little more guidance, any support professional referrals? Thank You

    You can try to load the javascripts (there are lots of it) in the footer instead of the header. http://wordpress.org/extend/plugins/footer-javascript/ This should speed up the loading time. Next to that: do a google search for javascript compression and give that a try.

    Reduce the images to a couple of bytes via compression, try to use a single css file instead of five.

    In the end, you maybe want to change your theme because it’s enormous.

    Hope I could help.

    surely, it took a lot of time to load,
    You got plenty of banners on the sidebar, also i saw a lot of things loading, if you are using javascript based stuff then its time to remove them…

    Thank you, all awesome advice, I have switched to swift theme and it is waaaay faster… installed the javascript to footer…massive improvement.

    Now to work on the new theme…. http://www.swiftthemes.com

    Page won’t load for me…

    Nine times out of ten speed issues with a self-hosted WordPress blog are due to plugins however ocassionally the theme itself is the issue. Test this by swiching your theme to the default theme at a time when you expect the least traffic. Reset your browsers cache between steps to ensure accurate results. If it is still loading slow next disable your plugins and reactivate them one at a time until you pinpoint the problem. If you are still getting a slowdown after switching themes to the default and disabling the plugins I would contact your hosting provider and have them take a look at the connection.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘My Site is running slow… any support appreciated’ is closed to new replies.
Skip to toolbar