W3 Total Cache
[resolved] My site is down after updating (32 posts)

  1. Mike Strato
    Posted 3 years ago #

    Hi, I see other threads similar to this but I should start my own.
    I used the dashboard plugin updater to update W3 Total Cache yesterday. After 'plugin installed successfully' I pressed return to plugin page and then Nothing! My site is a blank white page. I can't get to the dashboard at all. Not sure what to do and I am not a Code afficianado.
    please advise how I can revert or fix or anything.


  2. casshern83fr
    Posted 3 years ago #

    maybe this link can help you Fix The WordPress Blank Page Error

  3. Mike Strato
    Posted 3 years ago #

    I attempted a couple things listed there to no avail yet.
    Since this happened when I updated W3 Total-Cache, I renamed that folder. This gave me an error and said to reload the plugin.
    I then renamed the Plugin folder and I get a 500 error.
    Refering to the link above, I can't tell if I have extra blank lines as I don't really know what I am looking for.
    anybody have any suggestions?

  4. gxt
    Posted 3 years ago #

    I have the same problem! Anyone?

    every mothaf**** time there's an update of this plugin there's ALWAYS, something that doesn't work... next time I'll not update. Do you even test it before release?

  5. johndoej
    Posted 3 years ago #

    I've had a similar problem with this plugin.
    Fortunately, I was able to get into the admin area and disable it.

    The websites have been completely messed up since the last updates due to this plugin. It's a pain to use and update. I can't even tell if something works or not any more. It's TERRIBLY BROKEN, just kill it with fire!!!

  6. gxt
    Posted 3 years ago #

    The only solution at this time is to Downgrade, 'till the developer decides to release another update.

    • export your current settings (Performance > General Settings > Import / Export settings)
    • deactivate + delete the plugin
    • download some of the older versions: http://wordpress.org/extend/plugins/w3-total-cache/developers/
    • upload it and activate
    • import settings if needed!

    it works for me :)

  7. Mike Strato
    Posted 3 years ago #

    @gxt. I can't even access my admin dashboard to do what you suggested even if I knew how to proceed afterwards.

  8. gxt
    Posted 3 years ago #

    ok, do it via ftp:
    open your ftp program and go to

    and delete all the files listed below:
    • db.php
    • advanced-cache.php
    • object-cache.php
    • w3-total-cache-config.php (first try to see if you can access your website without deleting this, if not deleted it)

    and the folder:
    • w3tc-config

    then go inside the /plugins/ folder
    • /wp-content/plugins/

    and delete the folder named:
    • w3-total-cache

    that should work! :)

    after you did those things, if you get a white page with some errors saying wordpress can't load w3 cache, RELOAD FEW TIMES THE PAGE and it'll get fixed.

    P.S. about my comment above and downloading an older version, it's better to download the version or lower!!!

  9. Tommy Day
    Posted 3 years ago #

    The same thing just happened to me, but I can't even access the wp-content folder via FTP anymore to deactivate the plugin.

    This is bad.

  10. Mike Strato
    Posted 3 years ago #

    Thanks for the help. I didn't delete them, I just moved them to a new Directory folder. Everything listed. Refreshing only resulted in a HTTP500 error. I refreshed about 10 times.
    I was able to access a few pages of my site, just not the home page or admin. When I moved the above mentioned files, I could not access anything.
    I'm going to keep trying

  11. wimonews
    Posted 3 years ago #

    We had similar problems, the only thing that saved our buts is that I contacted MAXCDN on Sunday and I had great developer.

    We think there has been issues with the plugin for weeks even as much as month.


    Yesterday, I disabled the plug-in completely and am waiting to see what to do next.

    We feel for you Mike, keep breathing and you'll figure things out. Did you have an backup of your entire site before the update? Sometimes it's easier to go back in time.

    Best Wishes

  12. gooma2
    Posted 3 years ago #

    Hey Mike,

    You might also want to check out your htaccess file since W3TC doesn't erase that data when it's uninstalled or deleted.

    Mainly this should be in your htaccess file without W3 Total Cache.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    My server and site has been down since 6:00 last night so I understand everyone's frustration.

    Interestingly my hosting (InMotion) had recommended W3 TC, but after all this mess, they've let me know that they're going to be recommending WP Super Cache since they've had a huge amount of sites going down in the past 24 hours with the upgrade.

    The plugin works great when it's set perfectly, but it can be a real bear when one thing is off. The fact that it can take down a beefy dedicated server like mine makes me very nervous with it too. My hosting is amazing at fixing any issue, but this one has had them stumped.

  13. gooma2
    Posted 3 years ago #

    and what's worse is I paid $100 to get it configured for my site through the W3 Total Cache service. When employees of the developer can't configure it to work without taking down your site, you know there's an issue.

  14. Mike Strato
    Posted 3 years ago #

    my HTPaccess file has quite a bit more then that in it. It all starts with #Begin W3TC browser cache.
    So I should delete all that down to "# Begin WordPress"?
    I'll probably save the file as it is,move it elsewhere and then edit.
    that should be okay, right?
    thanks alot

    I backed up my site about a week ago. So some stuff would be lost, but not much.

  15. gooma2
    Posted 3 years ago #

    definitely back that up just in case of any problems, but that code is the basic one for any WP site just to have you completely cleaned out from W3 Total Cache.

    I've had to clean this plugin plenty of times and always start with that in htaccess as clean start.

    Hopefully that will get you back up.

  16. gxt
    Posted 3 years ago #

    hmm that's strange...
    try clearing your browser's cache or try with another browser, then try also to login again here: yoursites.name/wp-login.php

    if that doesn't work, open PhpMyAdmin. Then select the WordPress database, and browse inside the "wp-options" table. Look for the "active_plugins" column, and click edit. Inside the "options_value"
    Those lines you see there represent the active plugins in your blog. Delete them all and click save. This should deactivate all plugins. Now check if your blog is live again, and if the admin area is working. They should be.

    Here's also a blog post on how to do that ( http://perishablepress.com/quickly-disable-or-enable-all-wordpress-plugins-via-the-database/ )

  17. gxt
    Posted 3 years ago #

    Damn! I forget about the .htaccess file. Yep, that may be also the problem...

  18. Mike Strato
    Posted 3 years ago #

    I really appreciate all the help. Nothing has worked so far but I haven't tried the phpmyadmin mentioned above yet. See what that does.

  19. gooma2
    Posted 3 years ago #

    be really careful with the phpadmin as that can't be undone if anything goes wrong.

    definitely a good idea to back up your database just in case.

  20. Jose Freitas
    Posted 3 years ago #

    With i had a error: "The directory w3tc can be deleted. (...) However, do not remove the w3tc-config directory".
    With the plugin activated the site is white, without the content.
    Deactivated, is goog.
    So, deactivated for now.

  21. Mike Strato
    Posted 3 years ago #

    @josefreitas2. I can't even go into dashboard to deactivate, or downgrade to a previous version.
    Also, I do not see a w3tc-config directory, just a w3tc directory.

  22. gooma2
    Posted 3 years ago #

    your w3tc-config directory will be in the wp-content one.

    this plugin spreads itself all over so you have to look in more than one spot which sucks when you don't know that and they don't really let you know.

  23. dmkizer
    Posted 3 years ago #

    Go to this YOUR DOMAIN NAME/wp-admin/ to access your dashboard, FYI.

    Rather than a blank page, I get a page filled with random code characters. It is somewhat intermittent; it was fine after I updated, then the site was down later. I have verified on two machines and three browser types that deactivating the W3 Total Cache plugin is the correct fix for this.

    I intend to try downgrading. To export the settings, I will need to reactive the current version though, which (of course) will mean breaking the site temporarily. I will do this at some time of day when I anticipate minimum traffic.

  24. gooma2
    Posted 3 years ago #

    Good idea to wait for slow traffic day. For anyone who's got a high traffic site, it's really tough with upgrading since the caches need to rebuild themselves. If you have a lot of traffic going on at the same time, it can easily overload your server.

    Also learning what caching your host provider has in place is very important as I've learned the hard way how interdependent they all can be with W3TC.

    You can also download your configuration setting from the w3tc-config folder right in your wp-content folder. If you look in the master.php, it will give you your settings. It's not as easy as exporting the config file, but at least if you're not able to activate it, you've got the settings.

  25. Mike Strato
    Posted 3 years ago #

    Hey all, thanks for your help with this issue. Unfortunately none of what was suggested worked for me. So I ended up calling my hosting and they restored to a previous date. Now I know the procedure on how to do this if any shit happens again. I only lost a few posts, and what I was working on at the time.<scratchin my head trying to remember what that was>
    Now I am going to make a full backup after any significant uploads and also before I do any bloody updates.
    cheers! and thanks!

  26. mbrsolution
    Posted 3 years ago #

    Hi @Mike Strato sorry to hear that you had to revert to a backup which was not updated and you lost some post and what ever you were working on.

    The good thing about this incident is that you have learned a huge lesson and that is to always have a current backup. This is something that I emphasize to all my clients and on most of my tutorials. This is an action that I have put to practice now for some time.

    If your issue is resolved sort of speak could you please close this ticket.

    Thank you kindly.

  27. M Asif Rahman
    Posted 3 years ago #

    If you could get access to your dashboard, you should deactivate the plugin and activate again. Then I checked all the setting again, and it worked for me. Only thing that had issue is CDN. Issues been discussed at this support thread, specially about MaxCDN or NetDNA. I have wrote a detail blog post about how to solve.

  28. Keating
    Posted 3 years ago #

    dmkizer, I have the same issue as you. Just disable page cache on W3TC, it works.

  29. Keating
    Posted 3 years ago #

    What's with the abusive language in this thread BTW? You are using a free plugin.... If you want support from the developers before others then you should pay for it!

  30. Frederick Townes
    Plugin Author

    Posted 3 years ago #

    Folks still having issues, I'm sorry for the trouble. Changing the implementation of file management to use WP's own APIs has proven to be fatal. If you still have issues, please write in to support directly through our site or through the support tab of the plugin. We will find the issues faster that way and get things back to normal with updates faster that way also.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.