Support » Plugin: WP-Optimize - Cache, Clean, Compress. » My Site Broken

  • Resolved agenciaeffetivo

    (@agenciaeffetivo)


    I just updated to WP-Optimize 3.1.7, then I wipe all settings and started again.

    Now it is not loading the js files… gzip compression is not working…

    The problem is in my site or with plugin version?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter agenciaeffetivo

    (@agenciaeffetivo)

    Sorry,

    Now the site is working. I wipe all settings and re-do again. Now it is working.

    Gzip compression is not working. Before update it was work.

    Plugin Support Harshad

    (@bornforphp)

    @agenciaeffetivo Can you please explain in detail, what makes you feel GZIP is not working, do you see any message in WP-Optimize > GZIP?

    Thread Starter agenciaeffetivo

    (@agenciaeffetivo)

    Hi,

    My cloudflare is under development mode and unchecked compression of html, css and javascript.

    But I got this message of wp-optimize:

    Gzip compression is already enabled. It seems to be handled by Cloudflare.

    BTW: I am with this issue, but your plugin is GREAT!

    Thread Starter agenciaeffetivo

    (@agenciaeffetivo)

    Now:

    1. I clicked on button Wipe Settings.
    2. On gzip enable tab: Enable button I got this message:

    We successfully added Gzip compression settings into .htaccess file. However, the test file we fetched was not Gzip-compressed. Possible causes include that Apache (your webserver) is not configured to allow .htaccess files to take effect, or one of Apache modules – mod_filter or mod_deflate – is not active, or the webserver is configured to disallow Gzip compression. You should speak to your web hosting support to find how to enable it.

    I understand this message, but I have gzip, mod filter and mod deflate enable. I already tested with Another plugins and it works.

    Plugin Support Harshad

    (@bornforphp)

    @agenciaeffetivo Can you please try to disable and then enable the GZIP button and check if the message goes away?

    Thread Starter agenciaeffetivo

    (@agenciaeffetivo)

    There are no button to enable/disable.

    Now I see this message: Gzip compression is already enabled. It seems to be handled by Cloudflare.

    If I remove all configurations, then I can see the button Enable. But it is not works.

    I think your plugin the best (I tested all others), the only issue is about this gzip compression.

    Please consider as a bug.

    Plugin Support Marc Lacroix

    (@marcusig)

    Hi @agenciaeffetivo

    Could you share your website’s URL?

    Marc

    Thread Starter agenciaeffetivo

    (@agenciaeffetivo)

    http://www.tecnomega.com.br

    Do you want acess to admin panel?

    Plugin Support Marc Lacroix

    (@marcusig)

    Hi @agenciaeffetivo

    My cloudflare is under development mode and unchecked compression of html, css and javascript.

    But I got this message of wp-optimize:

    Gzip compression is already enabled. It seems to be handled by Cloudflare.

    While you set development mode in CloudFlare, the assets are still compressed. You can see it here:

    screenshot

    Your content isn’t compressed using Gzip, but with Brotli, which is the alternative used by CloudFlare.

    Marc

    Thread Starter agenciaeffetivo

    (@agenciaeffetivo)

    Hi,

    I know about the brotli.

    At this moment I disabled brotli, proxy, minification and I am with devolpment mode ON.

    Then, I clicked on wipe button (your plugin), I then click on Enable cache it works!!! I am making some progress.

    1. Now I got headers from Google Chrome [please see the image, I do not know how to attach the image here] https://tecnomega.com.br/wp-optimize1.png

    2. I came back on your plugin panel, under tab gzip compression, I got this message:

    https://tecnomega.com.br/wp-optimize2.png

    3. Seems your plugin is working fine, but showing a wrong message.

    Let me know what do you think?

    Thread Starter agenciaeffetivo

    (@agenciaeffetivo)

    Hi,

    You can consider this issue solved!

    I can use gzip or brotli now. The only thing is the message about gzip in the cloudflare.

    But everything is working fine!

    Your plugin is great!!!

    Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘My Site Broken’ is closed to new replies.