Support » Plugin: Yoast SEO » My site break after an update

  • Resolved immanuelconrad

    (@immanuelconrad)


    After updating the plugin to the new version I cannot edit o create a new post or even page.
    my website is working well but when i try to create a post or page the site breaks
    There has been a critical error on your website. Please check your site admin email inbox for instructions.

    Learn more about debugging in WordPress.

    Fatal error: Uncaught Exception: GuzzleHttp requires cURL, the allow_url_fopen ini setting, or a custom HTTP handler.
    in /Users/Israel/Sites/folec/html/wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/functions.php on line 105

    Call stack:

    YoastSEO_Vendor\G\choose_handler()
    wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/HandlerStack.php:37
    YoastSEO_Vendor\G\HandlerStack::create()
    wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/Client.php:64
    YoastSEO_Vendor\G\Client::__construct()
    wp-content/plugins/wordpress-seo/src/config/semrush-client.php:69
    Yoast\W\S\C\SEMrush_Client::__construct()
    wp-content/plugins/wordpress-seo/src/generated/container.php:1256
    Yoast\W\S\G\Cached_Container::getSEMrushClientService()
    wp-content/plugins/wordpress-seo/src/generated/container.php:649
    Yoast\W\S\G\Cached_Container::getSEMrushLoginActionService()
    wp-content/plugins/wordpress-seo/src/generated/container.php:2693
    Yoast\W\S\G\Cached_Container::getSEMrushRouteService()
    wp-content/plugins/wordpress-seo/vendor_prefixed/symfony/dependency-injection/Container.php:271
    YoastSEO_Vendor\S\C\D\Container::get()
    wp-content/plugins/wordpress-seo/src/loader.php:216
    Yoast\W\S\Loader::load_routes()
    wp-includes/class-wp-hook.php:287
    WP_Hook::apply_filters()
    wp-includes/class-wp-hook.php:311
    WP_Hook::do_action()
    wp-includes/plugin.php:478
    do_action()
    wp-includes/rest-api.php:506
    rest_get_server()
    wp-includes/rest-api.php:464
    rest_do_request()
    wp-includes/rest-api.php:1984
    rest_preload_api_request()
    array_reduce()
    wp-admin/edit-form-blocks.php:77
    require()
    wp-admin/post-new.php:72

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Carl B

    (@devnihil)

    @immanuelconrad We’re sorry to hear you are experiencing this error after a recent update. Can you confirm you are using WordPress 5.5.1? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/

    If you have already confirmed that both Yoast SEO and WordPress are up to date and the error is still occurring, we would next recommend performing a conflict check to determine whether another plugin or theme is interfering with the Yoast plugin.

    The fastest way to do this is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Nineteen. Test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin allows you to run a conflict check without affecting normal visitors to your site.

    If you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts.

    I think yoast plugin is the cause of the error. i deactivated all the plugins expect yoast plugin but the error was there and even switching the theme to default. But when i deactivate yoast plugin i was able to create/edit a post or a page without any error.

    WordPress version 5.5.1
    Current theme: OceanWP (version 1.9.0)
    Current plugin: Yoast SEO (version 15.1)
    PHP version 7.2.19

    Error Details
    =============
    An error of type E_ERROR was caused in line 105 of the file /Users/Israel/Sites/fole /html/wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/functions.php. Error message: Uncaught RuntimeException: GuzzleHttp requires cURL, the allow_url_fopen ini setting, or a custom HTTP handler. in /Users/Israel/Sites/folec/html/wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/functions.php:105
    Stack trace:
    #0 /Users/Israel/Sites/folec/html/wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/HandlerStack.php(37): YoastSEO_Vendor\GuzzleHttp\choose_handler()
    #1 /Users/Israel/Sites/folec/html/wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/Client.php(64): YoastSEO_Vendor\GuzzleHttp\HandlerStack::create()
    #2 /Users/Israel/Sites/folec/html/wp-content/plugins/wordpress-seo/src/config/semrush-client.php(69): YoastSEO_Vendor\GuzzleHttp\Client->__construct(Array)
    #3 /Users/Israel/Sites/folec/html/wp-content/plugins/wordpress-seo/src/generated/container.php(1256): Yoast\WP\SEO\Config\SEMrush_Client->__construct(Object(Yoast\WP\SEO\Helpers\Options_Helper))
    #4 /Users/Israel/Sites/folec/

    Plugin Support Suwash Kunwar

    (@suascat_wp)

    Hi @immanuelconrad,

    Sorry for the trouble.

    Unfortunately, we’re unable to reproduce the issue on our setup. In fact, we recommend the PHP version 7.3 or above. To confirm further, can you please contact your webhost and upgrade it? Before you upgrade to a higher PHP version, check if your WordPress site is ready for it. Read this help article to learn how to update your PHP version.

    In addition, please ensure whether cURL is enabled.

    And again am getting this error
    Oops, something has gone wrong and we couldn’t complete the optimization of your SEO data. Please click the button again to re-start the process.

    Plugin Support Suwash Kunwar

    (@suascat_wp)

    Can you please try the following:

    1. Install & activate the Yoast Test Helper plugin
    2. Go to Tools -> Yoast Test
    3. Hit the “Reset indexables & migrations” button
    4. Delete the Yoast SEO plugin from your site. This won’t delete SEO data and settings.
    5. Re-install the plugin.
    6. Click the “Click here to speed up your site now” button.

    Can you please let us know if this solves the issue?

    HI @suascat_wp I just rolled back to the old version it is working fine thank you

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We are sorry to hear that you had to roll back to the prior version to fix the issue. Since we were unable to reproduce the issue on our end, it’s very hard for us to say what exactly causing the issue for you.

    In this case, we’d like you to please report this issue directly at our development here https://github.com/Yoast/wordpress-seo/issues to see whether they can find anything for you.

    @immanuelconrad how did u roll out to old version?

    Hi @jeevanshetty i used WP Rollback plugin

    @immanuelconrad thank you, but I just uploaded an old plugin it worked.

    Furthermore, even I am facing the same problem. Did u find solution?

    • This reply was modified 1 month, 1 week ago by jeevanshetty.
    Plugin Support Carl B

    (@devnihil)

    @jeevanshetty ​In regards to your inquiry about how to revert back to a previous version of the Yoast SEO plugin, please note that previous versions of the plugin may not be secure or stable and are available for testing purposes only. However, if you wish to download a previous version of the plugin and revert to it, ​you can do so by performing the following steps:

      • ​Visit https://wordpress.org/plugins/wordpress-seo/
      • Click on the ‘Advanced View’ option (this is beneath the plugin version information near the bottom)
      • ​Under ‘Previous Version’ select the version
      • ​Click the ‘Download’ button.

    After downloading the version of the plugin you wish to revert to, it can then be installed by performing a manual install/update of the plugin. We have instructions on how to install/upgrade the plugin manually at the following link: https://kb.yoast.com/kb/how-can-i-update-my-free-plugin/#ftp. You will need an FTP program such as FileZilla and your FTP details, which can be obtained from your host provider.

    Plugin Support Carl B

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.