WordPress.org

Forums

[resolved] My rss feed does not work with firefox (5 posts)

  1. nicola
    Member
    Posted 9 years ago #

    my feed works fine with opera,
    it does not with firefox.
    here it is
    http://www.nicoladimaria.info/blog/feed/

    here's my feed analized by a feedvalidator
    http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fwww.nicoladimaria.info%2Fblog%2Ffeed%2F

    what can I do ?

    `nicola

  2. iand
    Member
    Posted 9 years ago #

    Can you explain exactly what does not work? It seems fine in my version of Firefox and also via bloglines so things look like they are working.

  3. jwwf
    Member
    Posted 9 years ago #

    I'm having the same problem but I think I know what the answer is. The string <?xml version=blahblah> should be on the first line of the output, but there's an extraneous line feed. That tends to upset IE and many of the newsreaders (I've tried MyYahoo! and a few others and they doesn't like the output either).

    If you take the RSS output and put it in a text editor, then remove the extraneous empty line at the top, the newsreaders like the xml file then.

    I've been combing through the code to see who's outputting the extra line feed before the xml tag, but haven't found it yet. I'll keep looking and post what I find if I find it.

  4. iand
    Member
    Posted 9 years ago #

    jwwf - extra lines at the top of your RSS feeds tend to be caused by plugins from my experience. Have you tried going through and turning plugins off one by one to see if you can diagnose further?

  5. nicola
    Member
    Posted 9 years ago #

    I removed that stuff and now it works even with firefox

    thanks

    `nicola

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags