My Readers Cannot Post Comments...tells them 'we can't find what you're looking (19 posts)

  1. bakers001
    Posted 3 years ago #

    Hi...I've been running a WordPress blog for about four years now and have never had an issue with it until now. Recently, about a week ago, my readers started telling me they cannot post comments. When I tried to post a comment on a recent blog post, I was taken to a page that said:

    This is somewhat embarrassing, isn’t it?

    It seems we can’t find what you’re looking for. Perhaps searching, or one of the links below, can help.

    A list of my recent blog posts was then listed below. To my knowledge, I haven't done anything to my blog recently, so I'm stumped as to what could have happened. My blog address is below. Please help!


  2. That is a bit odd. I would try to re-install the theme is I were you. Perhaps one of the templates got modified somehow.

    Hopefully that will sort it out.

  3. bakers001
    Posted 3 years ago #

    Thanks, Christine...I'll give that a shot. Would it be too much trouble if I ask how to do that? Never done it before and I don't see an option for it in the Theme section of my Dashboard...

  4. bakers001
    Posted 3 years ago #

    I upgraded my theme to Twenty Twelve but it is still doing the same thing...??

  5. I would try deactivating all the plugins. This is very strange behaviour.
    I suspect that a plugin might be causing havoc.

  6. bakers001
    Posted 3 years ago #

    Ok, I deactivated all the plugins...now, when I try to post a test comment, my browser tells me that the page cannot be opened because there are too many redirects while trying to open it. I've tried both the Safari browser and Firefox, and it's doing the same thing...? Please help...I'm getting discouraged.

  7. YOu mentioned that you upgraded to Twenty Twelve, but I'm still seeing Twenty Eleven theme. Can you try switching themes? I still think that my initial thought was correct and there's a bug in the theme.

  8. bakers001
    Posted 3 years ago #

    Hmmmm...ok, I put Twenty Twelve back into play and it's still giving the same error message:

    The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

  9. Sorry @ bakers001, I'm really not sure what's going on.
    I did a Google search WordPress error 301 and came up with a bunch of stuff. I'm really not sure what's going on with your site.

    Maybe check some of these other links. There's mention of plugins and htacesss file



    I'm sorry I couldn't find the solution for you.

  10. bakers001
    Posted 3 years ago #

    Ok, thank you...I'll give those a shot. Have a good night!

  11. Eric Mann
    Posted 3 years ago #

    I tried loading your site, and the home page works just fine. But when I try to go to any individual post, it tries to redirect me to the same post.

    Accessing http://matthewscottbaker.com/blog/2012/11/06/movie-review-double-feature-fairy-tales-1978-full-moons-grindhouse-collection-auditions-1978/ attempts to redirect me to http://matthewscottbaker.com/blog/2012/11/06/movie-review-double-feature-fairy-tales-1978-full-moons-grindhouse-collection-auditions-1978/

    So it looks like you have a redirect set up somewhere that's breaking things. Are you using any kind of redirection plugin? Have you recently changes your permalinks? Can you copy and paste the contents of .htaccess so we can check to see if that's what's causing the issue?

  12. bakers001
    Posted 3 years ago #

    Hi, Eric. Thanks for reaching out.

    I haven't changed my permalinks to my knowledge, and I disable all my plugins yesterday (after I tried that, I reactivated Akismet, so it's the only one running). As for .htaccess, I don't see that file anywhere...?

  13. Eric Mann
    Posted 3 years ago #

    .htaccess is usually hidden because of the leading . in the filename. I'm not sure what you're using to access the server, but you might need to tell it to show hidden files.

    The .htaccess file is what tells Apache how to rewrite URLs. If you're running with no plugins, then that's likely what's causing the redirect issue. It's also the only way pretty permalinks can work (it tells Apache how to pass the pretty permalink into WordPress).

    One other thing to try is just resetting your permalinks. Go to Settings >> Permalinks in the admin. Change back to the default (?p=xxx) and save. Then change back to the setting you're currently using and save. WordPress should flush out your .htaccess file for you ... this might be just the fix you need.

  14. Edit: Doh! Eric beat me to the reply by at least a minute. ;)

    Any chance you an temporarily disable permalinks to the default of ?p=123

    So that


    can be reachable via


    It's only for a little while for troubleshooting.

    Something is tossing HTTP/1.1 301 Moved Permanently which you can see via this curl command.

    $ curl http://matthewscottbaker.com/blog/2012/11/06/movie-review-double-feature-fairy-tales-1978-full-moons-grindhouse-collection-auditions-1978/
    jan@dixie:~$ curl -I http://matthewscottbaker.com/blog/2012/11/08/book-review-siblings-2012/
    HTTP/1.1 301 Moved Permanently
    Date: Thu, 08 Nov 2012 16:14:25 GMT
    X-Pingback: http://matthewscottbaker.com/blog/xmlrpc.php
    Location: http://matthewscottbaker.com/blog/2012/11/08/book-review-siblings-2012/
    Content-Type: text/html; charset=UTF-8
    Age: 0
    Connection: close
    Server: YTS/1.19.11

    Those redirects are odd. These work


    But these looks missing.


    Which may mean you don't have a complete WordPress 3.4.2 set of files.

    All else fails, try the usual troubleshooting steps (some of which you've done already):

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    Please let us know how that works out.

  15. bakers001
    Posted 3 years ago #

    I think this is a permalink issue.

    I reinstalled the WordPress 3.4.2 update and it let me get back into my individual posts again. I had the default permalink setting activated, so it let me act like I was making a a comment post, but it never showed me any of the comments; I changed the permalink setting back to the way it used to be and now its giving me the redirect problem again...any ideas?

  16. The YTS web server is supposed to be Apache-ish (from what I understand) so there maybe/should be an .htaccess file somewhere. Do you have access to your file system via FTP or some other means?

    As Eric had said, if you can post the contents of that file here that may help find the problem.

  17. bakers001
    Posted 3 years ago #

    I've got access to my file system through my Yahoo Blog Manager; I've looked through every file and directory and don't see an .htaccess file. From what Yahoo help is telling me, they don't allow custom .htaccess files to be uploaded...now I'm even more confused than ever...

  18. bakers001
    Posted 3 years ago #

    I've got several .php files, though...

  19. mikeheiser
    Posted 3 years ago #

    I'm also having a comments problem. It just started two weeks ago after years of use without a problem. Readers tried to post a comment and got a 403 error message. I read about that problem on the forums, contacted my host, and got that to stop appearing -- but the problem of not being able to post comments persists. I have deleted Bad Behavior, have deactivated all my comment plug ins and still no success.

    My blog is at http://www.michaelheiser.com/PaleoBabble

    Does anyone have any suggestions? I've had thousands of comments over the years and would like that to again be an option, but have no idea what to do. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.