WordPress.org

Support

Support » Plugins and Hacks » [Resolved] My posts are stuck on UTC and also getting duplicates

[Resolved] My posts are stuck on UTC and also getting duplicates

  • I didn’t see a setting in the plugin to set my timezone, but my WP timezone settings are correct. I’m UTC -7 and everything else appears correct.

    The reason this is an issue is because all new tweet-posts are going into “Scheduled” rather than “Published”. I tried adjusting the settings to push the new tweets to “Draft” (that worked), then back to “Published” (that didn’t). When I open one of the scheduled tweet-posts in the editor, it shows that it’s schedule to be published seven hours later (UTC time).

    Also, I’m getting several duplicates popping up sporadically. And yes, I have RT’s and @replies turned off. What gives?

    http://wordpress.org/extend/plugins/twitter-posts-to-blog/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author badbreze

    @badbreze

    you’re self hosted?

    The timezone is hard-coded to UTC so it defaults to this regardless of what your wordpress is set to.

    Edit the code using the plugins editor (admin.php I believe, don’t have the code in front of me) and change the date_default_timezone_set to the correct timezone listed here.

    Sorry, it’s in twitter-posts-to-blog.php – 8th line down.

    Plugin Author badbreze

    @badbreze

    Removed timezone from code

    acostanza

    @acostanza

    I don’t know why or how, but I have the same problem where Tweets are getting scheduled for UTC time. I have deactivated and reactived the plugin, still getting scheduled instead of posting instantly. I double checked the version and I have 1.4.6.2 I also checked my WP Settings time for the server and it is set to NY timezone, which is mine. Any ideas on how to make the tweets post right away instead of being scheduled?
    Thanks!

    acostanza

    @acostanza

    Update: Fooling around with the UTC offset in the Network Admin (this is a site in a WP Network install) does nothing. However, changing the UTC offset in the Settings does cause the Tweet to be posted immediately. While this is a short-term workaround, the server time is now 5 hours off and so are the posts. Any insight is appreciated!

    Plugin Author badbreze

    @badbreze

    update to latest version this may solve your problem

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] My posts are stuck on UTC and also getting duplicates’ is closed to new replies.