Support » Fixing WordPress » My posts are not posting

  • I just recently lost the ability to post properly to my blog. The problem might be linked to the Autosave function somehow. I can save and publish posts as long as I do it before the Autosave function activates, as long as the post is short without links. Once WordPress begins to Autosave my post becomes stuck on “Saving Draft…”

    If I then go to either “Save” or “Publish” my post vanishes into the abyss. I simply get my “404” page for when a page does not exist on my website. If I copy and paste a larger bit of text into my post and attempt to post it, I experience the same problem. It is thus linked to the autosave function, yet isn’t at the same time. I am very, very confused.

    I just upgraded to 2.2 in the hopes that this would fix the problem but unfortunately it did not. The problem first came about out of nowhere last weekend.

    I deactivated all of my plugins. I have tried to post in Firefox, IE, and Opera. I simply can’t post properly.

    I encounter the same problems whether or not I am using the visual editor or the html editor.

    If it helps any my site is located below:

    This problem has crippled my blog so if anyone can help me I would really appreciate it. Thank you very much.

Viewing 4 replies - 1 through 4 (of 4 total)
  • bradyjfrey


    I have a similar problem… and it affects as worldwide blogging system for a security company (ouch). I’m looking at two things I’m going to try:
    1) wp-includes/script-loader.php on line 35 change the value from ‘120’ to ‘9999’ and see if it extends it so far that it becomes a negligable problem
    2) do the same for wp-admin/admin-functions.php on line 204 (though this seems to override an autosave after a true save)

    I’ve debated just removing the JS line for the autosave but I don’t know if that’ll cause larger issues. I’m going to try the above and pray it doesn’t cause a problem!



    This SEEMS to have atleast delayed the auto save, but I’ll wait a bit longer throughout the day to see what happens. Even though this is a repeated issue, it seems wordpress is not too interested in adjusting it:

    Both the user and the developer comments were inappropriate I’d say. Regardless the larger issue seems that autosave does not consistently work – in my environment it is saving security posts that don’t need to be saved. The idea of autsave is irrelevant for me then, so turning it off makes sense. But I’m customizing it, so wordpress doesn’t care too much for that.

    Well, that doesn’t fix my issue, sadly. I hit save or publish and get taken to post.php, but it’s actually the front page of my blog…weird, huh? My drafts aren’t saving or publishing at all.

    I’m no server admin, but I recently had similar issues and this code into my .htaccess file fixed it:

    <Files admin-ajax.php>
    SecFilterInheritance Off
    <Files index-extra.php>
    SecFilterInheritance Off
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    That middle bit is for pretty permalinks, so if you’re not using those, you can just do the first and last bits. In fact, just the last bit (3rd section) is the fix for the 404.

    Again, with a grain of salt as it worked for my on my host (LAMP, cPanel, reseller/shared host, WP 2.2 +, etc.). Hope it helps.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘My posts are not posting’ is closed to new replies.