Support » Fixing WordPress » My post won't show up on the blog

  • I have been posting to my blog for 10 weeks and then I did not post for several months. When I tried to post again, the post did not show up on the blog. The most confusing part is: my post is there on the dashboard. It says it’s published with the date I published it AND if when I hit preview it looked perfect on the blog…but it’s not there. I have deleted it and re-published it but it does not show up.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator t-p

    (@t-p)

    have you tried:

    -deactivating ALL plugins (yes, all) temporarily to narrow down the problem. If the problem goes away, re-activate them individually (one-by-one) to find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive).

    -switching to the unedited default theme for a moment using the WP dashboard. If you don’t have access to your admin area, you can switch to the default theme by renaming your current theme’s folder in wp-content/themes via FTP or SFTP or whatever file management application your host provides. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

    OK, I deactivated all plugins. Nothing changed. I have no problem getting into my dashboard and I view my last post. It looks fine but it’s not there when I go to the blog. Since I have no problem getting into the dashboard, what do you suggest?

    Moderator t-p

    (@t-p)

    have you tried switching to the default theme?

    No, I have no idea how switch to the default theme. BTW – I keep getting this message on my dashboard since deactivating my plugins.
    Performance Warning: Page Caching is not enabled. Please install/activate W3 Total Cache Plugin OR WP Super Cache plugin under the Plugins menu. Contact support with any questions.

    I am totally confused. I have made no changes to my site since my last successful post. Nothing!! That’s why I cannot understand what has happened that my last post is not showing up on the site.

    Also, support for W3 Cache has checked this out a said it has nothing to do with his software.

    I am wondering if I should delete the entire site and repost everything as one post. If I do that I am concerned that nothing will show up.

    Moderator kmessinger

    (@kmessinger)

    You can try activating W3. Then you will have on the menu bar a place to clear the cache. That is the likely problem.

    If you post a url, I will tell you what post I see.

    I don’t see anything that says “clear cache”

    Do you mean: “performance” and then “clear cache”?

    Sorry it doesn’t say clear cache, it says empty cache

    Moderator kmessinger

    (@kmessinger)

    Do you mean: “performance” and then “clear cache”?

    Yes. I couldn’t remember the exact wording.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘My post won't show up on the blog’ is closed to new replies.