Support » Fixing WordPress » My Post Limited In Size From My IP Only – Why? How?

  • I was getting ‘server error’ messages suddenly when I, as admin, tried to make posts to one of my blogs. Posts larger than about 40 words, I found.

    I tried my other blog and the same thing happened.

    So I contacted my host and queried and he said that when he tried, via a proxy, he had no trouble ( I ‘lent’ him my keys).

    But he only tried small posts. I mailed him about this and haven’t had a reply about that angle yet. But I might not need one.

    Because I tried using a proxy, too, and I found I could post large posts with no trouble at all via the proxy. Though I still can’t do it via my home machine, i.e. my own IP.

    I tried with both blogs. The same result. I still cannot post anything bigger than about 40 words from my own IP but using a proxy I can post whatever I wish.

    Can anyone help with some idea of what is going on here? It can’t be my router and home config at all, surely, because it is allowing the traffic up to the proxy server okay.

    Not only that but it was allowing the traffic up to WordPress from my own machine, when it wouldn’t post, too – because the posts were there in draft form! Just wouldn’t post.

    Can’t be their server, surely, what would it care about IP posting to your third party software? It’d block completely or not at all wouldn’t it?

    So I suspect something with WordPress. But how can that be? Nothing has changed. I upgraded one blog and it now has the latest version (and has had it during all this) but the other blog is at the last version.

    I need informed help….

    ๐Ÿ™‚

Viewing 9 replies - 1 through 9 (of 9 total)
  • So everything was working fine until you upgraded the blog and then you had the issue with the posts? You didn’t activate any new plugins or switch themes?

    Can you give a little bit more detailed description about the server error messages you are getting as well please.

    Thread Starter abrogard

    (@abrogard)

    Yes, but no.

    I mean Everything was working fine until I upgraded the blog and I did activate new plugins.

    BUT – it happens on a blog that again ‘was working fine’ and which I DIDN’T upgrade and DIDN’T activate plugins to.

    AND – I just created a new blog in the last half hour and immediately tried to post a few hundred words and – boom – same error…

    I will provide details of the server error message but it is very sparse. On another thread where I asked a less pointed question about this happening it was suggested I get the error log from the server if they’ll give it to me.

    I’m communicating now (finally) with the support staff at awardspace and might get that log soon.. maybe..

    ๐Ÿ™‚

    Thread Starter abrogard

    (@abrogard)

    Here’s the error message I get:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Yeah that doesn’t provide a whole lot of information as to the issue that could be going on (not your fault). I would try to get some more detailed error logs from your host to see what is happening.

    Keep us updated.

    Thread Starter abrogard

    (@abrogard)

    And I should add there’s been later developments that make this question no longer true as it stands.

    Because I used the proxy connection to commence cleaning up the blogs – removing all the small test posts that I’d got in there… sending them to trash is what I was doing.. and then suddenly the proxy got the same error message and served it up to me.

    This time all in tasteful shocking red – but the same message ‘internal server error and 500 error when looking for the error url’

    So it doesn’t just happen to me.

    If anyone wants to have a go and see for yourself you can use the test blog, I guess, don’t know why not.

    Awardspace have been offered the same facility. I don’t now what happens if numerous administrators try to log in simultaneously from different machines all over the world…

    Awardspace hasn’t caught on to what’s happening yet, I think, because they’re only at the stage of asking me for my IP so’s they can check they’re not blocking it… when I’m installing blogs from my control panel on their server and posting small posts, etc…

    So anyway the username is admin and the pswd is admin (very secure, eh) and the test blog is at peterturtle.com/blog – help yourselves.

    When I say a ‘big’ post I found anything over about 40 words (by WordPress’s count) would cause the hassle. And I’ve typically been trying to paste in and post about 500 words.

    ๐Ÿ™‚

    http://peterturtle.com/blog/?p=4

    I had no problem creating that post and publishing it, no errors whatsoever. The word count for the post is shown at 60.

    http://peterturtle.com/blog/?p=3

    I was also able to easily add in quite a few paragraphs to the draft post that you had on your site and publish it without any issues. I am not using a proxy.

    Thread Starter abrogard

    (@abrogard)

    Well thank you for that. I rushed immediately to try to duplicate your results and got the same error.

    After I click ‘submit’ I get a message that we’re ‘waiting for peterturtle.com and it hangs there for about a minute, maybe more, then the message.

    Do you want to try to reproduce your results on one of the other blogs? ploverpark.com/blog has ploverpark, ploverpark as the keys. go for it.

    I just tried again on the test blog – peterturtle – and it hung up from my machine and it hung up from the proxy, too. Uploaded 100% to the proxy and then just hung, no error message, blank white screen, it’s still there..

    I’ve heard nothing from awardspace and I think that though your trial seems to indicate it is okay there is something wrong or the proxy wouldn’t play up.

    And if there was nothing wrong – that brings it back to me, doesn’t it? But what on earth could I be doing wrong? Sending bad codes mixed in with my packets somehow?

    Thread Starter abrogard

    (@abrogard)

    Yes, how much can it have to do with me, my machine at home? Like what’s the chances of the problem being here?

    What’s happening? WordPress is not even installed here, is it? Only on my domain host. What do I see here when I’m posting in WordPress? It is a browser app that’s running, right? Written in PHP.

    I’m getting everything from my host’s server. And everything I see is going to his server? What about saving drafts? That seems a bit quick and then later we wait while sending the post up to the host. So are drafts saved in a temp file here somewhere for a while?

    But what I’m getting at is I’m totally constrained by the setup of the WordPress installation on the host server, right? I can effect virtually nothing.

    So it is extremely unlikely that any virus or whatever that I might have and don’t know about is causing this trouble. Right? Or Wrong?

    Thread Starter abrogard

    (@abrogard)

    Here’s the error log for one of my aborted posts:

    ipolli.com] [Sun Dec 05 23:26:09 2010] [error] [client 203.171.115.83] File does not exist: /home/domains/ipolli.com/favicon.ico
    [ipolli.com] [Sun Dec 05 23:27:37 2010] [error] [client 203.171.115.83] (70007)The timeout specified has expired: Error reading request entity data, referer: http://ipolli.com/blog/wp-admin/post.php?post=213&action=edit
    [ipolli.com] [Sun Dec 05 23:28:37 2010] [error] [client 203.171.115.83] (70007)The timeout specified has expired: Error reading request entity data, referer: http://ipolli.com/blog/wp-admin/post.php?post=213&action=edit
    [ipolli.com] [Mon Dec 06 00:47:07 2010] [error] [client 206.113.193.50] File does not exist: /home/domains/ipolli.com/robots.txt
    [ipolli.com] [Mon Dec 06 03:01:25 2010] [error] [client 209.249.53.99] File does not exist: /home/domains/ipolli.com/robots.txt
    [ipolli.com] [Mon Dec 06 08:34:06 2010] [error] [client 203.171.115.83] File does not exist: /home/domains/ipolli.com/favicon.ico
    [ipolli.com] [Mon Dec 06 08:37:11 2010] [error] [client 203.171.115.83] (70007)The timeout specified has expired: Error reading request entity data, referer: http://ipolli.com/blog/wp-admin/post-new.php?post_type=post
    [ipolli.com] [Mon Dec 06 08:38:11 2010] [error] [client 203.171.115.83] (70007)The timeout specified has expired: Error reading request entity data, referer: http://ipolli.com/blog/wp-admin/post-new.php?post_type=post

    My host provider (awardspace) maintain the whole problem is my slow connection and say ask my IP why it is slow.

    But I don’t have a slow connection. My connection speeds check out okay.

    This is the only connection anywhere that gets screwed up like this. I can even make this particular WordPress transaction as long as I go via abm.me – abm.me doesn’t complain about the connection….

    does anyone have any ideas?

    Perhaps I should start a new thread…. I think all this ‘abrogard last post’ makes it look abandoned… too hard… I’ll just leave it overnight or a few hours…..

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘My Post Limited In Size From My IP Only – Why? How?’ is closed to new replies.