Support » Fixing WordPress » my page titles don't show up anywhere

Viewing 13 replies - 1 through 13 (of 13 total)
  • Do you really mean Pages as opposed to Posts?

    In many (maybe most) themes, Pages (not Posts) do not automatically show up if you are using a WP Menu rather than the default.

    Are you using a custom Menu defined in Admin->Appearance->Menus?

    A great deal depends on your theme. If you are using a free theme, post a link to your site here and it may help get an answer. If you are using a paid theme, you should contact the theme supplier.

    Thank you for your suggestions – I appreciate your help! My blog site is I am just trying to set it up and got stuck immediately when I tried to get the page titles to appear under the banner. As you can see, there are no page titles at all, although on the back end it says they are published. I guess is is a free theme through wordpress, although I paid Bluehost for hosting.

    Thanks so much for any suggestions!
    Susan Letourneau

    From what I see you are very new to WordPress – so not easy to explain. It looks like you have a few items that are not as what you were expecting. That is WordPress for you when you are very new to it.

    If you don’t mind let me suggest a few things you can do for a little while until you become more familiar with WordPress.

    You didn’t like the title on top of the theme – picture. You can leave it blank for now. Later come back to this.

    I checked you site and there were no pages. Pages are for static info, like About Us. When you log in on your left you will see ‘pages’ click on Add Page and you will be creating a new page. Fill it up with something. Then view your site as a visitor. You can delete it if you don’t like it.

    Again you will see on your left ‘Posts’ when you move the cursor over this (for version 3.3.1) you will see ‘Add Post’ click on it and add a post and fill it up with some writing.

    Go down to Settings on your left and you will (click on it or just move the cursor over it) see Reading, Click on Reading. It shows ‘Front page shows’ click on ‘Your latest post’ if it is not selected. On the next line it shows ‘Blog pages show at most’ change the value from 1 to 2 to 3 to 4 and view your website as a visitor. Save changes before viewing.

    Then you will see the difference between a Page and a Post. Just keep adding post and playing around with your WP. Later you can change your theme to move the your title somewhere else.

    I hope that helps you

    Thank you so much Peter for writing that all out! I appreciate that very much. My problem is that I have done all those things but my page titles do not show up on the top of the page under the picture, even though my dashboard tells me I have 6 static pages and they are all published. Yet they do not show up and I have no idea why! It’s incredibly frustrating!

    Moderator kmessinger

    (@kmessinger) should come up with this url unless in dashboard you have chosen to open with a static page.

    You might want to spend some time here,


    It sounds like you need to create a menu, then add the pages to that menu, and set that menu to show. The menu function will normally show in your theme options or in the appearance section.

    Hope that helps.


    I checked your website again and it appears the page menu has disappeared. Even ‘Home’ is not there. I installed WP in a new temporary sub-directory, on my site, to see if I could simulate your experience. But I could not make the pages menu disappear.

    It could be that something went wrong during the installation of WordPress and / or some files were corrupted. Could you uninstall WP from your system and then reinstall again? I have not use Bluehost so I do not know whether they have an ‘Applications Installer’ or a script like Fantistico to install and uninstall your WordPress. You can ask your host tech support to do this for you.

    Then clear your browser cache and then log back into WordPress to see if it works properly.

    I would like to suggest that you go to Settings | Permalinks and set Common Settings to ‘Post name’ then save changes. This will make your links SEO friendly.

    See how that goes.

    Please backup your site before you do anything else.

    Don’t uninstall WP – you will have to reinstall all your plugins, reset your wp-config.php file, etc. This is a last resort.

    Instead, try this. Go to Admin->Dashboard->Updates and click ‘Reinstall Now’. That should install a fresh copy of WP without losing anything.

    @kmessinger had a good point that is why I had suggested making your links SEO friendly.

    @vtxyzzy, what you suggested is good if this was a working WP site with many pages, posts and plugins but this is an empty site.

    I suggested the uninstall and install procedure as I wanted to know if the problem was from the host and not WP (very unlikely) or with the installation of the WP. Corruption can occur if there are hardware problems with the host but this is very rare. Another cause of corruption is if the host is overloaded. For these two reasons I had suggested that the host tech support help with the uninstallation and installation.

    @susanletourneau a new installation should look like this

    It is much easier and faster to reinstall than to completely wipe out the site and it may work.

    Thank you all so much for your help, and especially to Peter who went to the trouble of actually trying to duplicate my problem! I tried the various suggestions and finally gave up and hired someone from to solve the problem, which he was able to do. So now my blog is up and running well.

    I really appreciate all the suggestions you all have made, and for taking the time to consider my problem and to think about what might help.

    Thank you, Thank you for helping me to get up and running on wordpress!

    Susan Letourneau

    Care to share what caused the problem? And use the dropdown near the top right to mark this topic ‘Resolved’ so that others with the same problem can find the solution.

    Hi there guys,

    I am new to WordPress and was hoping that one of you could please help me. I have used a free theme called Photogram for my site. Everythings seems to be going fine. Except my pages appears under my Slider. I don’t want it there, seeing that the pages are under each Menu already. Please help ! The link to my site is:

    I would really appreciate any advice.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘my page titles don't show up anywhere’ is closed to new replies.