Support » Fixing WordPress » My media library is by default storing in wp-include/image folder

  • Hi,

    I am getting these errors,

    Notice: Trying to get property 'ID' of non-object in /home/bbb/public_html/wp-includes/post.php on line 6530
    
    Notice: Trying to get property 'post_type' of non-object in /home/bbb/public_html/wp-includes/post.php on line 6764
    
    Notice: Trying to get property 'post_type' of non-object in /home/bbb/public_html/wp-includes/theme.php on line 3013
    
    Notice: Trying to get property 'post_type' of non-object in /home/bbb/public_html/wp-includes/theme.php on line 3241
    
    Notice: Trying to get property 'post_type' of non-object in /home/bbb/public_html/wp-includes/post.php on line 4479
    
    Notice: Trying to get property 'ID' of non-object in /home/bbb/public_html/wp-includes/post.php on line 4479
    
    Notice: Trying to get property 'post_type' of non-object in /home/bbb/public_html/wp-includes/post.php on line 3940
    
    Warning: Creating default object from empty value in /home/bbb/public_html/wp-admin/includes/post.php on line 708
    
    Notice: Undefined property: stdClass::$ID in /home/bbb/public_html/wp-admin/post-new.php on line 67
    
    Notice: Undefined property: stdClass::$post_status in /home/bbb/public_html/wp-admin/edit-form-blocks.php on line 99
    
    Notice: Undefined property: stdClass::$post_type in /home/bbb/public_html/wp-admin/includes/meta-boxes.php on line 1375
    
    Notice: Undefined property: stdClass::$post_type in /home/bbb/public_html/wp-includes/taxonomy.php on line 226
    
    Notice: Undefined property: stdClass::$post_type in /home/bbb/public_html/wp-includes/taxonomy.php on line 229
    
    Notice: Undefined property: stdClass::$post_type in /home/bbb/public_html/wp-admin/edit-form-blocks.php on line 387

    However by installing “Classic Editor” plugin these issues resolved, but now my media library is storing in Wp-content/images folder..

    Some of things which I have already tried:

    – Disable all the plugins
    – Change permissions of folder
    – Activate default theme
    – Install Health Check (doesn’t work everything seems to be fine)
    – Reinstall the Fresh copy of WordPress

    • This topic was modified 2 months, 3 weeks ago by  endopakistan.
Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.