WordPress.org

Forums

Quick Page/Post Redirect Plugin
[resolved] My links with "?" (question mark) do not redirect... (5 posts)

  1. Max L
    Member
    Posted 2 years ago #

    My links with "?" (question mark) do not redirect...
    Request: /detail?Purple-Food-Trailer-36
    Destination /inventory-view/purple-food-trailer/

    Possible solutions? (I do not use jQuery)

    Thanks...

    http://wordpress.org/extend/plugins/quick-pagepost-redirect-plugin/

  2. indyjoey
    Member
    Posted 2 years ago #

    On a linux based box? If so... quick redirects will need to be done with rewrite rules via your .htaccess file.

    See http://www.simonecarletti.com/blog/2009/01/apache-query-string-redirects/ for details.

  3. Adam
    Member
    Posted 2 years ago #

    @indyjoey - Isn't that the point of the plugin, so that we don't have to open up our htaccess file and write some code?

    @Max L - I'm getting a similar error:

    For example, I want "/about/the-company/" to redirect to "/the-company/". After creating a "quick redirect", I get "example.com/the-company/?about/the-company/=" with the additional redirected URL slugs after the final destination page. Anyone have any thoughts?

  4. Adam
    Member
    Posted 2 years ago #

    Here's a solution... use this plugin, it works perfectly: http://wordpress.org/extend/plugins/simple-301-redirects/

  5. prophecy2040
    Member
    Plugin Author

    Posted 2 years ago #

    These should work ok in the latest version (5.0.3).
    regards,
    Don

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.