WordPress.org

Support

Support » Plugins and Hacks » [Resolved] My Jetpack stats are gone gone gone

[Resolved] My Jetpack stats are gone gone gone

Viewing 15 replies - 1 through 15 (of 17 total)
  • Howdy!

    Would you mind providing me with a link to your WordPress blog so that I can look into this for you?

    Cheers!

    Thank you SO MUCH for responding. My WordPress site is http://www.raisingtroubledkids.com In case this helps, the Support from Hostgator told me that Jetpack does not work with the most current version of WordPress 3.5. I was also told I cannot ‘downgrade’ this to the previous one (3.42) in order to get Jetpack to run again.

    esmi

    @esmi

    Forum Moderator

    the Support from Hostgator told me that Jetpack does not work with the most current version of WordPress 3.5.

    Uh? I don’t think your support person knew what s/he was talking about,.

    Jetpack should function with no problems on WordPress 3.5.

    Can you let me know what happens when you try to access your stats–are your old ones simply missing, or does an error occur? When did this issue begin?

    The problem started about 10 days ago, and it was out of the blue. When I click on Jetpack Stats, the little spinner goes around and around, no matter how long I wait, and the stats never download. All I recall is that a couple of plug-ins were updated around that time. I have since deactivated and deleted ones I was not using, and experimented deactivating others to see if it helped. Still no stats.

    Thanks for helping me with this.

    Plugin Contributor Tim Moore

    @tmoorewp

    @puckette: do your stats show up if you log in via a different browser? If so, it is likely a cache issue with the browser you use most often.

    I too get no stats with jetpack on any browser — I’ve updated to 3.5 twice, and updated jetpack, re-configured, logged out, you name it — it all worked fine until 3.5

    site is elffactory.org

    Plugin Author Jeremy Herve

    @jeherve

    @lashbo Are you able to access your stats on WordPress.com?
    https://wordpress.com/#!/my-stats/?

    I also noticed a small issue with your site: could you edit the footer.php file of your theme, and look for the following code:

    <?php wp_footer ?>

    You will want to move this code up a bit, and place it above the closing </body> tag.

    Hey Jeremy –

    Thanks for the check, yes I can see the wp stats.

    I can’t however find that string in the footer.php file — it’s a weird theme, with all kinds of formatting issues so maybe that’s why.

    Plugin Author Jeremy Herve

    @jeherve

    Could you try to switch to a different theme, and see if that helps?

    I also noticed that your site uses an old version of jQuery, instead of using the one that comes bundled with WordPress. This could cause the Stats issues you reported earlier, and can be caused by your theme or one of your plugins.

    If switching themes doesn’t help, could you try to deactivate all your plugins one by one, in order to find out which one adds this old version of jQuery to your site?

    You can find out more about jQuery conflicts here:
    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4#post-3547424

    unfortunately I’m stuck with this theme because of the donation ticker

    Plugin Author Jeremy Herve

    @jeherve

    Alright. Could you look for the function loading this old version of jQuery then, and remove it? It could be a single line in header.php, or a function in functions.php.

    Similar issues
    http://www.collegeparentcentral.com
    Only just today upgraded WP to 3.5
    I’ve gone through the routine everyone else seems to be, of de-authorizing and disabling things.
    Also tried switching to the 2012 theme.
    No stats, endless spinner, etc
    Stats appear to show at wordpress.com, and I do see the “sparkline” when I view the site while logged in.
    Theme appears to me to be loading jQuery 1.8.3
    Another anomaly, but I don’t know if this is new – some of the UI in the dashboard is disabled (for example, clicking the “Screen options” or “Help” tabs don’t do anything). I seldom use those, so I can’t tell you if the behavior is new or not.
    Thanks for any insight.
    Steve

    Plugin Author Jeremy Herve

    @jeherve

    @steve Is mod_pagespeed enabled on your server? It might indeed create issues with Javascript on your site and on your dashboard, and that would explain the problems with the Stats, the Screen Options and Help buttons.

    You can read more about it here:
    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4#post-3547424

    Thank you SO much, Jeremy!
    It turned out not to be mod_pagespeed, but the link you provided nailed it. I was impressed by the PerishablePress Blacklist and included it in my htaccess file, but I wasn’t aware that it breaks parts of version 3.5 and has been updated.

    For any other security-conscious webmasters who came across that code and included it in a pre-3.5 era, hustle over and grab the updated version here:
    http://perishablepress.com/5g-blacklist-2013/

    Thanks again, Jeremy. I’m SO grateful you pointed me to that link.
    Steve

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] My Jetpack stats are gone gone gone’ is closed to new replies.