WordPress.org

Support

Support » Plugins and Hacks » My hooks in my custom functions.php aren't working.

My hooks in my custom functions.php aren't working.

  • I have my functions.php file in the root directory of my child-theme. The total contents of the file is shown below:

    <?php
    remove_action( 'woocommerce_single_product_summary', 'woocommerce_template_single_title', 5 );
    add_action( 'woocommerce_before_single_product_summary', 'woocommerce_template_single_title', 5 );
    remove_action( 'woocommerce_before_single_product_summary', 'woocommerce_show_product_images', 20 );
    ?>

    I would greatly appreciate any help, thank you

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Roy Ho

    @splashingpixelscom

    What are you trying to do and what version of WooCommerce are you using?

    All of the changes are on the single product page, so I’d like to: 1)Remove the product title and add what I want as my title into my product description (What I’m importing into my title only suits my needs on my product pages)
    2)Remove the single product image so I can position the image where I want it
    3)If at all possible, eliminate the single product page and have a lightbox open instead with a title of my choice, description, price and add to cart button

    Oh yeah, I’m using WordPress 3.5.1 with twenty twelve theme and Woocommerce 2.0.3

    thank you

    Roy Ho

    @splashingpixelscom

    I just tested the hooks you’re trying to use and it works fine for me.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘My hooks in my custom functions.php aren't working.’ is closed to new replies.