Support » Plugin: SSL Insecure Content Fixer » My Home Page is Insecure

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author webaware

    (@webaware)

    G’day navins,

    Have you changed your site URL and home URL to HTTPS? That’s in general settings:

    Settings > General

    If you want to force your website to be totally HTTPS, here’s how to do it for Apache web server via your .htaccess file:

    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    For nginx, use separate server blocks for HTTP and HTTPS, like this:

    server {
        listen         80;
        server_name    example.com;
        return         301 https://$server_name$request_uri;
    }

    NB: if you have had this server for some time and expect there to be some form posts to your website on HTTP, replace 301 with 307.

    cheers,
    Ross

    navins

    (@navins)

    Hi Ross,

    Thanks for helping! I tried both options but still, boringengineer.com opens insecure but the http://www.boringengneer.com opens up secure. What else you think that I might need to take care?

    My .htaccess file

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Thanks,
    Navin S

    hifrench

    (@hifrench)

    Hi there at first i should better to say i’m not a professional and my prob. is the same ! my home page isn’t just seure and for example i click on a post and when that page is opened i get the green lock !!!! when i searched i web it was written press F12 and got to the security tab and finde your probm. i did it but i found these :
    ” Mixed Content: The page at ‘https://hifrench.com/’ was loaded over HTTPS, but requested an insecure font ‘http://hifrench.com/wp-content/plugins/master-notification/inc/front/fonts/fontawesome-webfont.woff2?v=4.5.0’. This request has been blocked; the content must be served over HTTPS.”
    i don’t know how to fix it , please help me like an amateur ! thanks a lot .

    navins

    (@navins)

    Guys, I was able to fix this issue. I installed a plugin called “Really Simple SSL” in my WordPress and it fixed the issue.

    Hope it works for others as well!

    webaware,

    I was having a problem with my website being insecure. I followed your instructions to change the address to https:// and now I can’t load the website on any browser. Here: https://pegasuslaw.org/ I can’t seem to find any way to get back to the admin panel either.

    Plugin Author webaware

    (@webaware)

    G’day @wilsonza,

    Your website does not have a valid TLS (SSL) certificate. You need to speak to your host about that.

    You can regain access to your website on http (not https) by adding these lines near the top of your wp-config.php file:

    define( 'WP_SITEURL', 'http://www.comtechmt.com' );
    define( 'WP_HOME', 'http://www.comtechmt.com' );

    Once you’re back in, check the HTTPS settings.

    https://ssl.webaware.net.au/https-detection/

    Then check that you can access the site correctly from HTTPS before removing those lines from your wp-config.php file.

    cheers,
    Ross

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.