WordPress.org

Forums

my-hacks? (7 posts)

  1. boneless
    Member
    Posted 10 years ago #

    I've installed authimage.php to prevent comment spam. It works (only sometimes no image and therefore no possibility to comment), but why should i make the suggested my-hacks.php? when I activate it in the wp-control panel, i get error messages in my blog. When I deactivate it, no errors and the plugin seems to be working anyhow.

    So why is my-hacks so important?

  2. Kafkaesqui

    Posted 10 years ago #

    Q1:What instructs you to enable my-hacks? The AuthImage material? Does it tell you to add anything to it?

    Q2: Do you have anything in the my-hacks.php file?

  3. boneless
    Member
    Posted 10 years ago #

    A1: yes, the authimage but also I saw something mentioned about it in this forum

    A2: yes, the following:
    <?php

    session_start();

    ?>

  4. Kafkaesqui

    Posted 10 years ago #

    Ah, well then, the need for my_hacks.php would be important to a degree, since session_start(); is a (supposed) requirement of AuthImage.

    Not sure it needs to be called from my_hacks.php specifically, but to stick with it (for support's sake with the plugin), check to make sure the error messages are not syntax-related. Typically with PHP, this is due to one or more empty lines before the opening <?php tag, or after the closing ?> one. These two tags must enclose the entire file.

  5. boneless
    Member
    Posted 10 years ago #

    when I select 'use legacy my-hacks.php file support' i get the following errors immediately:

    Warning: session_start(): open(/tmp/sess_feabba02accae5497962b2806232e68e, O_RDWR) failed: Permission denied (13) in /home/virtual/site136/fst/var/www/html/my-hacks.php on line 3

    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/virtual/site136/fst/var/www/html/my-hacks.php:3) in /home/virtual/site136/fst/var/www/html/my-hacks.php on line 3

  6. Kafkaesqui

    Posted 10 years ago #

    Well that's not good.

    Again, check to make sure there's no syntax problem (i.e. spaces before and after the php tags.). Also, other than using my-hacks, an option (if, and I mean *if* there's a problem using AuthImage without it) is to place the

    start_sessions();

    call at the top of your index.php template within the first <?php ... ?>, before require("./wp-blog-header.php").

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.