Support » Themes and Templates » my ‘GreenTrack’ Theme(WP 1.5) for Download !

Viewing 15 replies - 1 through 15 (of 26 total)
  • Very nice theme. I have it running at my site.

    Looks great. 🙂 Thanks!

    A small bug in the Single.php is corrected.
    Please download it again from the same link.


    Very nice theme Sadish. I’ve only looked previously, this time I tried.

    There’s a lot of nice detail in there.

    Yes, ‘Greentrack’ is very nice. I am using it for a new non profit site.

    When I switch from Default to Greentrack theme, the “Pages” are no longer displayed in de menu bar. I’ve been searching for the code lines for ‘Pages’ in Greentrack, but cannot find them.

    Could someone with Greentrack-experience please help with this?
    This is my site :

    Thanks in advance!

    It looks fantastic, however, there’s an ‘e’ after every one of my titles.

    Check it out,

    Really strange, I dunno how it happened

    EDIT: Now it’s broken…weird…it works if you go to though (which is where wordpress is located).

    Anyone reckon they could give me a hand, here?

    The ‘e’ is so you can EDIT it. It is meant to be there.
    No one else can see it but the person who wrote the post.

    Is showing ‘Pages’ in the sidebar of ‘GreenTrack’ a forgotten feature?
    (Or is it me being stupid ;-))

    I tried everything I could imagine, but I can’t get this to work.
    Tried adding this to index.php :

    <h2><?php _e(‘Pages:’); ?></h2>

      <?php list_pages(0, ”, ‘name’, ‘ASC’, ‘/’, true, 0, 1); ?>

    Didn’t work, list_pages is an undefined call. It only shows the title ‘Pages’.

    I added the Page Template from the Default theme, but that seems to speak a different language…

    If someone could help me to solve this, I would be very grateful!

    Wow, don’t I feel dumb. e for Edit, of course.

    Thanks :p

    I was testing out GreenTrack on my site. Can anyone tell me why I get this:

    Warning: main(./wp-blog-header.php): failed to open stream: No such file or directory in /var/www/html/wordpress/wp-content/themes/GreenTrack/index.php on line 3

    Fatal error: main(): Failed opening required ‘./wp-blog-header.php’ (include_path=’.:/php/includes:/usr/share/php’) in /var/www/html/wordpress/wp-content/themes/GreenTrack/index.php on line 3

    Can anyone help me on this? Any help is much appreciated. Thanks!

    Nevermind! I figured out line 3 in ‘index.php’ which states:

    needed to read:

    Seems to work now. btw… Nice layout, Sadish! I’m looking forward to working with it. 🙂


    Firstly, always backup your files!

    This works fine with permalinks DISABLED, but if you enable them, when you click a page, archive, category, etc … the list of pages vanishes. I’m not a programmer so I don’t really know why but I’m looking into it.

    Step 01:

    – Open wp-content/themes/GreenTrack/index.php

    – Find the line:
    <h2>< ?php _e(‘Categories:’); ?></h2>

    – Before this line add:
    <!– START Pages addition –>
    <h2><?php _e(‘Pages:’); ?></h2>

      <?php wp_list_pages(‘sort_column=menu_order’); ?>

    <!– END Pages addition –>

    Step 02:

    – Open wp-includes/template-functions-post.php

    – Fine the line:
    if ( !isset($r[‘title_li’]) ) $r[‘title_li’] = __(‘Pages’);

    – Replace with:
    // if ( !isset($r[‘title_li’]) ) $r[‘title_li’] = __(‘Pages’);

    Step 03:

    – Upload both files, overwriting the originals!

    If you want to see what arguments wp_list_pages accepts, try here:

    We need someone to adjust the style sheet for a wordpress implementation. About an hours work…we will pay. We will laso have subsequent work if you’re interested.

    Please email

    Oh and I changed the ‘e’ to ‘**’ because it looked a bit silly and was annoying me haha.

    This is regarding how to add a Page section to the sidebar…

    The method posted above involves this hack:
    – Open wp-includes/template-functions-post.php
    – Fine the line:
    if ( !isset($r['title_li']) ) $r['title_li'] = __('Pages');

    I think that was to prevent the “Pages” header from showing up twice. I found a cleaner way to do it. Instead do this in index.php:
    <!-- START Pages addition -->
    <h2><?php _e('Pages:'); ?></h2>
    <?php wp_list_pages('sort_column=menu_order&title_li='); ?>
    <!-- END Pages addition -->

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘my ‘GreenTrack’ Theme(WP 1.5) for Download !’ is closed to new replies.