Support » Plugin: W3 Total Cache » My GDPR plugin does NOT work with W3TC activated

  • Resolved atutrabajo

    (@atutrabajo)


    Hello. I have been using your plugin for a long time and it has basically solved most of my site caching problems.

    First of all, thank you for that.

    On the other hand, another of the great “dilemmas” that I have to solve on my site is the following:

    I want to resolve the RGPD regulation but, to the fair and necessary extent.

    That is, as I understand it (and I am interested) … that the cookie bar appears ONLY when readers from the EU visit me!

    With that ONLY objective (since this bar particularly bothers me) I was desperately looking for (literal) a “something” that meets the same.

    And after much searching and, going through various “alternatives” (including a code that later turned out to be malicious :(, I came across this plugin, which meets ALL my expectations;

    https://wordpress.org/plugins/gdpr-cookies-pro/

    This is…

    – Load a simple but effective cookie bar.

    – It is presented ONLY to visitors from the EU.

    – Point.

    With this premise, as soon as I found it and, I read EVERYTHING about it (Features, Comments, Reviews, Etc.), I proceeded to download, install, configure, etc.

    After that and, as I always do when I try something “new” on my site, I deactivated W3TC, I entered my site from different IPs (I have installed a program that “disguises” the IP of my pc as if it were in other countries) and , I was able to observe (finally!) that, my cookie bar … worked EXACTLY the way I wanted! …

    That is, it was loaded where it had to be loaded (EU countries) and it did NOT do it where it should not (Latin American countries, etc.)

    But my joy did not last long because, as soon as I reactivated your plugin (W3TC) … the fucking bar did NOT appear again! …

    I honestly looked for ALL the information I could before turning to you.

    But so far, I did NOT find it back 🙁

    Please, could you tell me what to do?

    From already thank you very much.

    Greetings.

    PS: To save time and, based on what I was able to read, including your responses on the support channel, I add the following information;

    1) Name of the plugin for the cookie bar: GDPR cookies pro

    https://wordpress.org/plugins/gdpr-cookies-pro/

    2) Link to my website: https://atutrabajo.org/

    3) Configure current W3TC:

    [NOTE I: the following is the JSON file that is generated when within the W3TC administrator we click on the “DOWNLOAD” button in the “Export configuration” section]

    [NOTE II: Just in case, as I don’t know which platform they have access to (Dropbox or Drive), I am sending you a link to both possibilities :)]

    3.1) In Dropbox

    https://www.dropbox.com/s/qaclog5jxup8phc/atutrabajo.org.json?dl=0

    3.2) In Google Drive

    https://drive.google.com/file/d/1PMhuIWpVQYUA17ug7_wSgBOHAakVcKXc/view?usp=sharing

    I hope that all this information is enough to correct the aforementioned inconveniences.

    Again, thank you very much.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @atutrabajo

    Thank you very much for your words of support and I am sorry about the issue you are experiencing.
    I’ve checked the plugin you are using and I am not seeing any information if the plugin is compatible with the caching plugins or not. Some plugins like https://wordpress.org/plugins/cookie-law-info/ do offer Caching support only in Paid version of the plugin. Basically, the cookie consent bar should be fired with ajax to bypass the cache. As the mentioned plugin you are using is fairly new with only 500+ installations there is a possibility that they have not got to that point in development, or I may be wrong.
    Now I’ve tested the plugin you are using. First I’ve set it to show the notice to all, saved all settings, and purge the cache and the Cookie notice bar was showing every time (Clearing BC and visiting from another browser). After that, I’ve changed the configuration to Show only in European Union countries, saved the GDPR plugin settings, Purged the W3TC Cache and the result was that it was not showing to me (not in the EU) and checked it VPN and it’s showing.
    So, make sure that you save all settings and purge the cache in W3TC. Check if the plugin shows notice if the option Show only in European Union countries is disabled.
    If not, disable the W3TC settings one by one and see which option may be causing this (most likely Page Cache)
    Thanks!

    Thread Starter atutrabajo

    (@atutrabajo)

    Hi Marko.

    First of all, thank you for answering me. If it helps you, you are one of the few who takes this service of users seriously.

    That said, I must add that … you are a crack! (Or almost. And now I’ll tell you why 🙂
    Indeed you were right in that … “most likely the cache” … but not the page cache but, the minified.

    I tell you:
    – I did what you did. That is, I deactivated the plugin (GDPR cookies pro), the option to … “Show only in European Union countries” and, contrary to what happened to you, to me – even with this option deactivated – I did not the bar came out (nowhere 🙁
    With which, regarding … “Check if the plugin shows a warning if the option Show only in European Union countries is disabled” …, the answer is NO.

    Therefore I proceeded with, your 2nd. suggestion. This is…
    … “If not, disable the W3TC settings one by one and see which option may be causing this (most likely the page cache)” …

    That is, I went to Performance / General Settings and, of course, I started with the 1st. section (precisely “Page cache”). But there was NO case [Even with this disabled, the bar did NOT appear]

    – Then I continued with the 2nd. section, that of Minimize and … soooo!
    Not only did the bar go out, but it went out where it had to go (EU countries) and, it did not go out where it didn’t have to.

    Although, strictly speaking, this is something that I “suspected” because, as I told you, I was reading a lot (literal) and, in the meantime, I found a thread in the support of your plugin in which …
    – The same thing happened to a user but, with another plugin for a cookie bar (I think Cookie consent) and, like me, she opened a thread in this same support to find solutions.

    And among so many suggestions that they made, she found the answer herself because she said that …
    … “it was a problem with the minification of the javascript file, I excluded it from the minification and it worked” … (or something like that).

    – Another user, commented something about …
    … “If it can be of any use. I had problems with Asset Cleanup Pro (not shown here).
    The issue was related to css minification and was fixed by adding /plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css to the do not minify list “…
    However, in my case, NOTHING of that worked.

    I will tell you what I have already done so you can see if it can help in your diagnosis:
    1) In 1st. Instead, you will have been able to see in the links that I sent you when I opened this thread, the type of W3TC configuration that I currently have and that, as I also mentioned, works perfectly for me for everything … except for this! 🙁

    2) In 2nd. Instead, as you can see in these threads of the GDPR cookies pro plugin developer support …
    2.1) In this thread; https://wordpress.org/support/topic/geo-location-not-working-4/ in which, a user mentioned that precisely … “the geographical location does not work” … I explained how (based on my research and even based on a comment from the developer), I had managed to solve the problem in a timely manner.

    Basically, what I had done was, paradoxically, compress the js files of the plugin 🙂
    Not because he knew something but because, as you can see in this other thread, https://wordpress.org/support/topic/nice-but-it-wont-work/ the plugin developer himself mentions to another user that. .. “your cache plugin does not minimize the js file” … (Which is why I am struck by the fact that the problem is in minified caching 🙂
    Note: If you look at the link within the thread, you will see that when it says cache plugin, it means your competition (autooptimize).

    But going back to point 2.1) you will notice that, at that moment, I had found a solution to this same problem but …
    2.2) If you look at this other thread; https://wordpress.org/support/topic/error-message-instead-of-the-cookie-bar/ here “I retrace my steps” because, as I explain in it, after the last WordPress update to the version 5.6 (prior to the current 5.6.1), instead of getting a cookie bar, I got a horrible message.
    For this reason, I deactivated / deleted the plugin in question and decided to wait for the developer to find a solution for it.

    3) Since I had to solve this and after a lot of searching for options (literal), I went back to see if the plugin had been updated and, since I saw that it was supposedly updated to the latest version of WordPress (5.6.1), I decided try again, with the results I mentioned to you when I opened this thread.

    Therefore, I honestly don’t know what to do anymore, I’ll tell you about the (other) things that I (also) ALREADY tried:
    a) I went to the source code of my site and I noticed that, in the html they are repeated several times … “. gdprcp-cookies-bar” … So (following one of the many things I read out there), I went to Performance / Group Cache / Manage cookie groups, I created a group with that name (with and without period at the beginning), I activated (I left the box checked) and I deactivated (I distilled) the cache box, I added gdprcp- cookies-bar (with and without a dot at the beginning) in the Cookies box, I saved everything, emptied the caches, tried it and … NOTHING!
    Ergo, I deleted said group of cookies and emptied the caches to leave everything as it was.

    b) I opened my site again and, following another (one more) tutorial, I used the chrome inspector to go to Application / Cookies and find out which cookies (related to this plugin) were being loaded, I found ONE that is called precisely “gdprcp-country” and that, all it does is add the location of the browser, it returns to W3TC, I created another group with this name and, I repeated the operation described in a) and … NOTHING!
    Ergo, I deleted the group and went back to “sheet 0”.
    b.1) I noticed that the other groups I have have the “Enabled” checkbox unchecked and the cache checkbox checked. Ergo, I repeated the operation with “cookie-country” like this and … NOTHING!
    I deleted the group again and go to “page 0”

    c) Going back to “exclude from minification” I literally tried EVERYTHING.
    That is, I excluded from the minification one by one and, in different procedures (separated from each other), the following files (in their corresponding section):
    /public_html/wp-content/plugins/gdpr-cookies-pro/resources/css/gdprcp-admin.css
    /public_html/wp-content/plugins/gdpr-cookies-pro/resources/css/jquery.growl.css
    /public_html/wp-content/plugins/gdpr-cookies-pro/resources/js/gdpr-cookies-pro.js

    [Note: Of the latter – javascript – there are 4 other files but, honestly, I don’t think they have anything to do with it, they have these names: gdprcp-admin.js, jqColorPicker.min.js, jquery.growl.js and, jquery .sticky.js So, I opted – for now – with not trying anymore. Unless there are opinions to the contrary :)]

    Conclution:
    As you can see, we have to;
    1) The problem is in the minified cache because, when deactivating it, everything works correctly.

    2) I cannot leave this cache disabled because, as you know, my site would “inflate” like a balloon when, in itself, it is too “heavy” a site.

    3) Neither did it work: Create Cookie Groups or Exclude Files.

    Please could you help me?

    Excuse “the can” and from now on, thank you very much for your patience and attention.

    Greetings.

    PS: Just in case I didn’t make it clear;
    In this last opportunity, I re-uploaded the cookie plugin file as suggested by its developer (I downloaded the .zip to my pc, uploaded / installed / activated it) and then, I left my cPanel, I downloaded the js files one by one, I uploaded them to an online compressor, compressed them, downloaded them and uploaded them to my directory, replacing the “originals”.

    In other words, these files are compressed. But this is neither good nor bad “per se” since, as I mentioned in 2.1 this procedure had already worked well for me (until WordPress was updated to 5.6).

    On the other hand, even compressed, the files work correctly, as soon as I (as I explained at the beginning), I deactivate the W3TC minification cache.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @atutrabajo

    Thank you for the detailed explanation. It’s important that we’ve managed to find the source of the issue. However, we need to dig a little bit deeper.
    Re-enable minify, and disable the settings in Performance>minify one by one (HTML minify, JS minify, CSS minify) and see which one might be causing the issue.
    Make sure to save all settings and purge the cache after each option is disabled. Once we determine which option is causing this, we can exclude the files from being minified.
    Some notes, if the issue is related to HTML minify, make sure to change the HTML minified in Performance>General settings to HTML tidy and see if the issue persists. If the issue is with the other options JS/CSS, you should exclude the files.
    One thing that I’ve noticed is that the path of the files you added is incorrect you should add as following:
    For CSS

    /wp-content/plugins/gdpr-cookies-pro/resources/css/gdprcp-admin.css
    /wp-content/plugins/gdpr-cookies-pro/resources/css/jquery.growl.css

    For js:
    /wp-content/plugins/gdpr-cookies-pro/resources/js/gdpr-cookies-pro.js
    So without /public_html
    Let me know if this helps!
    Thanks!

    Thread Starter atutrabajo

    (@atutrabajo)

    Hi Marko.
    Thanks for answering.

    With respect to …
    … “Re-enable minify and disable settings under Performance> minify one by one (HTML minify, JS minify, CSS minify) and see which one could be causing the problem.” …

    I must say that, as I mentioned above, whenever I try something and, it doesn’t work, I return everything to how it was. That is, minification on my site was enabled.

    In fact, in the following screenshots you can see how I have configured my Minify area in W3TC;
    1) “General” section
    https://www.dropbox.com/s/lnes547wjiajj1s/Captura%20de%20pantalla%202021-02-17%2022.38.35.png?dl=0

    2) Section “JS”
    https://www.dropbox.com/s/h6r6nxbv9d8w7k2/Captura%20de%20pantalla%202021-02-17%2022.40.00.png?dl=0

    Note I: I show you this ONLY for information purposes, because I don’t want to have to change it since, as I already mentioned, W3TC covers ALL my expectations regarding cache but, yes and only yes, I have it configured the way you are seeing.

    Note II: At the time, too, I tried a large number of configurations but THIS is the one that is currently working for me in EVERYTHING I need (at the level of cache, loading speed, etc.). And also, it is the one that covers all my needs to “pass” the Pagespeed, Gmetrix, Pingdom, Etc. tests.

    But going back to this problem and, regarding …
    … “minify one by one” …
    Luckily I did not have to search much then, 1st. I tried HTML and it didn’t work (and yes, I returned everything to how it was 🙂 but, as soon as I deactivated JS … soooo!
    Not only did it work with the option “Only for EU visitors” activated, but the cookie bar loaded as it had to (only for EU visitors 🙂
    Now, once this was determined, I tried to try excluding (one by one at the beginning, all together at the end) the 5 Javascript files that the plugin contains, that is;
    /wp-content/plugins/gdpr-cookies-pro/resources/js/gdpr-cookies-pro.js
    /wp-content/plugins/gdpr-cookies-pro/resources/js/gdprcp-admin.js
    /wp-content/plugins/gdpr-cookies-pro/resources/js/jqColorPicker.min.js
    /wp-content/plugins/gdpr-cookies-pro/resources/js/jquery.growl.js
    /wp-content/plugins/gdpr-cookies-pro/resources/js/jquery.sticky.js

    But frankly, it did NOT work!

    Which is kind of weird because in theory it should have loaded the cookie bar, just like it does when I disable js minification for the entire site.
    Anyway.
    Just in case, I show you some screenshots of how I had configured the “Advanced” section:
    https://www.dropbox.com/s/sp1c2invp7kdejr/Captura%20de%20pantalla%202021-02-17%2022.44.25.png?dl=0

    And even, as I read something out there, I also tried this other way;
    https://www.dropbox.com/s/iyh4fwrpy4hmclu/Captura%20de%20pantalla%202021-02-17%2022.45.58.png?dl=0

    That is, this is how this Section had been, with the aforementioned js files (one below the other) excluded.

    But now (as always), I removed these files from “Exclude …” and it was like this;
    “Advanced” section (current);
    https://www.dropbox.com/s/r2a5drl2cv5q4om/Captura%20de%20pantalla%202021-02-17%2022.47.56.png?dl=0

    As you can see, I already tried everything and it DOES NOT work!
    So frankly, I don’t know what to do!

    In short, the problem is generated by the javascript minification but, I cannot leave it deactivated because, as you know, it would end up “inflating” (more) my site.

    I hope you can help me.

    Again, thank you very much.

    Greetings!

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @atutrabajo

    I’ve checked your website and saw that you are also using a rocket loader. That may or may not be a problem.
    However, I’ve also seen a console error: aaff2.js:1 Uncaught SyntaxError: Unexpected identifier and when checked the aaff2.js:1 it was all about the GDPR plugin, so some files still being minified.
    SO you should once again exclude them so I can check the console for any errors.
    There is also a possibility that you disable jquery migrate on the frontend in Performance>General settings and minified jQuery file, and since some files are dependant on jQuery possibly you also need to exclude jquery from being minified.
    THanks!

    Thread Starter atutrabajo

    (@atutrabajo)

    Hi Marko.
    I tell you that, following your instructions regarding …
    … “I should exclude them again so I can check the console for errors” …

    I have just left out the only 2 (two) files that mention something about said technology (jquery).
    This is;
    /wp-content/plugins/gdpr-cookies-pro/resources/js/jquery.growl.js
    /wp-content/plugins/gdpr-cookies-pro/resources/js/jquery.sticky.js

    In other words, the “Never minimize the following JS files” box remained like this;
    https://drive.google.com/file/d/1C310jLmCBcXXq_HWctItkkfKtP7o7N2_/view?usp=sharing

    And regarding …
    … “There is also the possibility that you disable jquery migrate in the interface in Performance> General settings and minified jQuery file” …
    I tell you that I had never seen this Section before, heh! It is probably due to the fact that, since I installed / configured your plugin (W3TC), I was testing configurations until it was as you can see in the JSON file that I sent you.

    But this section must have appeared in one of the many updates that your plugin had after I finished my last configuration.

    Ergo, since I had not seen it and, I did not find anything that made me see that it could be of use to me, I had never touched it. Up to now.

    However. Based on your recommendations, I just did what you suggest and, consequently, this section looked like this;
    https://drive.google.com/file/d/1MVw9zlC7OAZB0r8s_1_CZbbgVGz847V4/view?usp=sharing

    Finally and as for …
    … “and since some files depend on jQuery you may also need to exclude jquery so that it is not minified” …
    I don’t understand it so, I looked in ALL the source code of my site and, the only thing I found that refers to jquery, is this;
    https://www.mecagoenlos.com/jquery-3.2.1.min.js

    Also, it is an external file that executes a script so that some file files load asynchronously or lazyload (I don't remember anymore, heh!). That is, NOTHING to do with this.
    
    Having said that:
    1) What you suggest (it was installed as is in case you want to check it yourself) ... It did NOT work!
    2) Having done that of ... "disable jquery migrate in the interface in Performance> General settings" ... my videos DO NOT work!
    3) And what's worse, my site now, which was slow in itself ... It's SLOWER than before!
    In short, the cost / benefit of having implemented these recommendations is negative.
    
    This is...
    - I DO NOT get the cookie bar to activate
    - My videos DO NOT work
    - My site loads much slower
    
    I'm going to leave it like that so you can take a look at it and, depending on what you tell me, I'll put everything back as it was before.
    
    I await your comments.
    
    From already thank you very much.
    
    Greetings.
    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @atutrabajo

    Thank you for the information and I am sorry about the misunderstanding:
    1. The option “Disable jquery-migrate on the front-end” should be disabled so please do so
    2. I’ve checked your website and I can still see the console error associated with the GDPR plugin.
    I’ve tried to replicate the issue and I am not seeing the console errors on my end.
    Please try these settings.
    3. If the console error is still there after these settings are changed and you saved all settings and purged the cache YOu should try excluding other JS files associated with the plugin.
    Thanks!

    Thread Starter atutrabajo

    (@atutrabajo)

    Hi Marko.

    I am sorry that I was not understood.

    With respect to…
    … “1. The option” Disable jquery-migrate on front-end “should be disabled, so please do” …
    As I explained before, ALL of this section was always “disabled” well, I NEVER knew of its existence, until you mentioned it to me, heh!
    Ergo, this option is currently disabled, as you can see in this screenshot;
    https://drive.google.com/file/d/1Z1wCqYsicNkrCp4Wl3_ds7YRdutVoyMd/view?usp=sharing

    However, the cookie bar DOES NOT appear.

    Although, strictly speaking, in the previous thread, I understood that you had to “activate” it (tick it), and that is precisely what I wanted to show you with this link;
    https://drive.google.com/file/d/1MVw9zlC7OAZB0r8s_1_CZbbgVGz847V4/view?usp=sharing

    But the cookie bar NEVER appeared.

    And refering to…
    … “3. If the console error persists after changing these settings and saving all settings and purging the cache, you should try to exclude other JS files associated with the plugin” …
    On the one hand, you should know that I, I DO NOT know how to “read” console errors 🙁
    And on the other, after I replied to you in my previous thread, I also excluded ALL … “JS files associated with the plugin” … as you can see in this other screenshot;
    https://drive.google.com/file/d/1o9K7CWfYoB67b3UiFwElyXfLfuWMeENh/view?usp=sharing

    Therefore, currently, ALL these recommendations are or were ALREADY implemented on my site.
    
    And yet the cookie bar DOES NOT appear or ever did! :(
    
    Which is at least rare because:
    a) The cookie bar appears as soon as I disable the "JS minify Settings" completely.
    b) And this even when I didn't even know about the option of "User Experience / Disable jquery-migrate on front-end"
    c) The plugin has 5 javascript files but only 2 that say .jquery. However, the bar does NOT appear excluding these 2 but, neither, excluding the 5 (as I currently have).
    
    So I don't know what to do anymore! :(
    
    Could you help me?
    
    I await your comments and in advance, thank you for your patience.
    
    Greetings.
    
    P.d 1: If you want, I can resend the JSON file with ALL my current W3TC configuration. Or, you can ask me about a specific section.
    
    P.d 2: In my modest understanding, shouldn't we include W3TC, something that makes plugins without Ajax - as you say this plugin lacks - work the same?
    
    P.d 3: This should partly explain why this plugin has so few downloads. However, it is a good plugin and gathers all the features and functionalities that I need ...
    That's why, for almost a week that I have been (we are) reneging on this, heh!
    Thread Starter atutrabajo

    (@atutrabajo)

    Hi Marko.

    How’s it going, everything okay?

    Were you able to analyze the last thread I sent you?

    Something new?

    I’m still here, without the “blessed” cookie bar appearing on my site.

    And that’s despite the fact that, as I told you, I have ALL your latest suggestions implemented.

    In other words, my site currently has:

    1) The option “Disable jquery-migrate on the front-end” disabled.

    2) The 5 Javascript files of the plugin in question excluded.

    Anyway.

    As I told you before, frankly I don’t know what to do anymore 🙁

    Anyway, the following just occurred to me (let’s see what you think) …

    What if you, get into the plugin code and tell me which line I would have to modify whatever you tell me?

    And I know that, it is something that the plugin developer should do but …

    If you look at this;

    https://wordpress.org/support/plugin/gdpr-cookies-pro/

    You will see that the same …

    It has been more than 15 months since I have answered ANY questions!

    Please…

    Could you see if you can do something?

    Thanks in advance for your patience and willingness.

    Greetings!

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @atutrabajo

    Thank you for the information. I am not seeing the error no, however, there are a lot of errors in the console caused by the cloudflare rocket loader.
    So, can you please disable Cloudflare rocket loader, save all settings and purge the cache and purge the Cloudflare cache and see if the issue persists.
    Thanks!

    Thread Starter atutrabajo

    (@atutrabajo)

    Hi Marko.

    Thanks for answering. AND NO.

    I tell you that, that of …
    … “there are a lot of bugs on the console caused by the cloudflare rocket loader” …
    It is something that I also see but … I DO NOT understand! 🙂

    However, your observation just gave me an idea and that is, I am going to send the folks at Cloudflare the following screenshot …

    https://ibb.co/gjqRTd9

    Let’s see if it helps them to solve it.

    About…
    … “can you disable Cloudflare’s rocket loader, save all settings and purge cache and purge Cloudflare cache and see if the problem persists?” …
    I just proceeded as you suggest and yes the problem persists! (That is, the bar does NOT appear)

    Which is kind of weird because, as I mentioned in other threads:
    1) As soon as I deactivate the “JS Minification” of W3TC the problem is solved. And this is independent of EVERYTHING else.
    That is to say:
    – Whether or not the “Disable jquery-migrate front-end” box is enabled (checked) in the General Settings / User Experience Section
    – Whether or not the javascript files of the GDPR plugin are excluded in the box in the section “Minify / Advanced / Never minimize the following JS files” (as they are currently)

    2) As I also mentioned before, the developer himself in response to an observation from a user, regarding that … “the geographical location does not work” … he answers that …
    … “the plugin has a database with IPs from all over the world that is used for geolocation, that database weighs 3 megabytes approx and there is a possibility that the automatic installation has failed due to the weight” …

    Something that, if you want, you can read in this thread; https://wordpress.org/support/topic/geo-location-not-working-4/

    Color note: At the end of that thread you can see my comment “flattering” in 1st. instance to the plugin in question, heh!

    3) Similarly, the developer faced with another observation from a user that … “Nice but it won’t work” … replies that …
    … “your cache plugin doesn’t minimize the js file” … (?)

    As, if you want, you can read in this other thread; https://wordpress.org/support/topic/nice-but-it-wont-work/

    Color note II: In this other thread; https://wordpress.org/support/topic/error-message-instead-of-the-cookie-bar/ – which I opened – “I retrace my steps” and, instead of “complimenting” the plugin, I make a constructive criticism because, after WordPress was updated to 5.6.1, the plugin stopped working well.

    And also, I mention the steps that I followed in the beginning to make the plugin work and that, for this to happen, I followed their own “recommendations” with that of … “do not minimize the js file” …
    In fact, as I also mentioned, I did EVERYTHING the developer recommends. This is:
    a) I uploaded the plugin directly to my server.

    b) I downloaded to my pc, one by one, the 5 js files, I uploaded them to an online js compressor, I downloaded them again to my pc (already compressed) and, I uploaded them to my directory (as “replacement” of the originals).

    In other words, ALL the JS files of this plugin are already compressed.

    And then? They were? Should these files be compressed or not?

    However, as I mentioned, as soon as I deactivate Minify W3TC JS the cookie bar appears correctly (where it should appear).

    But obviously I can’t leave this permanently disabled, just for a single plugin to work 🙂

    So, like I told you, frankly I don’t know what to do anymore 🙁

    By last:
    Could you see if, in the code – either from W3TC and / or from the GDPR plugin – there is nothing we can modify, even manually, to make this work?

    I await your comments.

    Thanks a lot.

    Greetings.

    PS: The most “strange” thing is that, despite the fact that the GPDR developer has NOT responded to ANYONE for more than a year, I just observed that in the plugin repository it says that …
    … “Tested up to 5.6.2” … (the LATEST version of WordPress) (?)

    That is to say that, apparently, purplelightsoftware (that’s the name it uses), is out there but, does NOT want to “talk” to us 🙁

    A real “mischief” because, in my humble opinion, if you resolved this issue of the cache and “talked” a little more with your users, surely you would have many more downloads than you currently have.

    Anyway.

    It’s just an opinion, but if you can get it across, please do so.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @atutrabajo

    Thank you for the information.
    The only thing I can offer you at this point is to drop us a note directly via the support channel in Performance>Support so we can investigate the compatibility issue.
    Thanks!

    Thread Starter atutrabajo

    (@atutrabajo)

    Hi Marko.

    I’m sorry to tell you that what you suggest is NOT going to happen.

    Why?

    Okay. I just went where you suggest, that is to “Performance / Support” of your plugin (W3TC) and I came across this “surprise” 🙂

    https://drive.google.com/file/d/1FlFXQ0ZACcw2iPB8BDbo1xlD00dxmyYg/view?usp=sharing

    Which suggests to me that, in order to do what you recommend … I have to pay!

    And that is NOT going to happen because, with less than 10 average visits per day (as I currently have), my site (yet) is NOT economically sustainable.

    Which does not mean that, at some point “go through the box.” But not for now. Thanks.

    By last:
    – It is a pity that you did not suggest this to me before we started with this topic and / or that … It took you almost a week to suggest it to me! 🙁

    – Much more why, in all our conversation, I showed you thoroughly that …
    Both plugins (W3TC and GDPR) ARE incompatible!

    Anyway.

    What if it is going to happen is that, I will try another cache and / or cookie bar plugin.

    Or that, directly, I will run out of cookies bar 🙂

    After all, here in my country (Argentina), the GDPR is not even mandatory.

    Still, I really appreciate the time you gave me and, although you couldn’t / wanted / knew how to find the way around, you treated me with respect and a lot of patience.
    And I appreciate that.

    I also respect your work. And even that of the developer of the GDPR plugin (although he hasn’t answered anyone for more than 1 year, heh!)

    And I understand that, as in my case, you need to make your plugins economically sustainable.

    But in my case, I still can’t do what they suggest (Upgrade to a PRO product)
    Therefore, I can only thank you and regret that we have not found a “free” solution for you.

    One way or another, thanks for your time.

    Greetings!

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @atutrabajo

    Thank you for the information.
    Now, the fact that you are not seeing anything within the Performance>Support is not because you are not subscribed to the Pro version of the plugin, but most likely a temporary bug.
    You can also reach out to us via the website https://www.w3-edge.com/contact/
    I’ve told you that I was not able to replicate the issue, and this means that the plugin works as expected on my end using the W3 Total Cache plugin with JS minify enabled, please check the screenshot
    The only difference is that you still have Rocketloader enabled in Cloudflare which I suggested disabling and there is also a possibility that minify is enabled in Cloudflare also.
    So you should log in to your Cloudflare dashboard and disable the Cloudflare minify (if enabled) and also disable Reocketloader, save all settings and purge the Cloudflare cache and W3TC cache and that should be it.
    Thanks!

    Thread Starter atutrabajo

    (@atutrabajo)

    Hi Marko.

    If it’s like dice, I apologize for the misunderstanding.

    Having said that …
    – With respect to …
    … “the fact that you do not see anything in Performance> Support is not because you are not subscribed to the Pro version of the plugin, but because of a temporary error” …
    I tell you that said “temporary error” is still valid. That is, the same poster still appears, as you can see in this screenshot; https://ibb.co/rMcmqnc

    – As for …
    … “I told you that I could not replicate the problem, and this means that the plugin works as expected in My final using W3 Total Cache plugin with JS minify enabled, check the screenshot” …
    On the one hand, I can’t verify … “the screenshot” … well, I don’t see any screenshots 🙂

    And on the other hand, I could NOT replicate it because, the bar does NOT appear to me at ANY time.

    That is to say…
    1) It doesn’t appear to me when “Performance / General Settings / User Experience” has the “Disable jquery-migrate on the front-end” box checked or when it doesn’t. As you can see in the following screenshot; https://ibb.co/cx9GtvR

    2) Nor does it appear to me when in “Performance / Minify / Never minimize the following JS files”, I have excluded the 2 files that say jquery, nor when I exclude ALL the JS files that the plugin contains (which are 5). Not when I have them NOT excluded (as suggested by the plugin developer). As you can see in the following screenshot; https://ibb.co/7xfhCQM

    And finally…
    3) It also didn’t appear to me when I had “Cloudflare / Speed ​​/ Optimization / Rocket Loader” disabled, as you can see here; https://ibb.co/LZPjL83 Nor, when I had it enabled (as I just did now because – as I said – the test did NOT work).

    In conclusion:
    a) I have just deactivated / deleted the plugin in question (GDPR)

    b) I left everything as it was. Is that;
    b.1) In “Performance / General Settings / User Experience” the box “Disable jquery-migrate on the front-end” is unchecked.

    b.2) In “Performance / Minify / Advanced / Never minimize the following JS files”, there are NO excluded files.

    b.3) To “Cloudflare / Speed ​​/ Rocket Loader” I have it in “Activated”

    c) Please, could you tell me step by step how you did to enable the cookie bar on your pc?
    That is to say…
    c.1) Should I proceed as I did previously with the JS files? This is:
    c.1.1) Upload the plugin through my Control cPanel

    c.1.2) Download the JS files to my computer

    c.1.3) Compress them (with an online tool) and upload them again (already compressed) to replace the originals.

    c.2) Should I exclude JS files in “Minify / Never Compress …”? Or not?
    And if so, would it have to be all or just the 2 that say jquery?
    Would they have to include the slash from / wp-content or not? (Yes. I tried both ways, heh!)

    c.3) Would I have to leave “Cloudflare / Speed ​​/ Rocket Loader” permanently disabled? Or just to test?

    I’m asking you because, as I already mentioned, the only time it worked for me was when this happened …
    1) I uploaded the JS files of the plugin already compressed

    2) I didn’t have “Disable jquery-migrate on front-end” checked or, NO JS file excluded from minification in W3TC

    3) I had Rocket Loader enabled

    Butoo …
    It worked … As soon as I turned off “Performance / Minify / JS minify Settings”!

    So, as you can see, your results and mine are a kind of “mystery” 🙁

    I await your comments.

    From already thank you very much.

    Greetings!
    PS: AND NO. I never had or have minification enabled on my Cloudflare because, I read around (and also tried at the time 🙂 that it was too redundant.

    In other words, having it enabled in W3TC was more than enough.

    P.d 2: Just now that I entered WordPress.org you can see the “famous” screenshot that is mentioned in the email that I received (where as I told you, said capture is not seen).

    And what I observe is that you, you have “Minify / JS” configured the same as me, except that, I have the boxes …
    …”Elimination of protected comments (does not apply when” only combine “is active)”…
    …”Elimination of newlines (not safe, does not apply when “only combine” is active)”…
    Marked (checked) and you don’t.

    Could this have influenced my results?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘My GDPR plugin does NOT work with W3TC activated’ is closed to new replies.