Support » Plugin: Contact Form 7 » My forms is not submitting

  • None of my contact forms are submitting. Whenever I try and submit the form I get this error – “NetworkError: 404 Not Found – website_url/wp-json/contact-form-7/v1/contact-forms/17007/feedback/”

    {“code”:”rest_no_route”,”message”:”No route was found matching the URL and request method”,”data”:{“status”
    :404}}

    The forms were working absolutely fine before but yesterday after we updated the contact form 7 plugin it stopped working. Kindly address this issue asap as this is a very important concern for us.

Viewing 12 replies - 16 through 27 (of 27 total)
  • I have fixed the issue on my server. In my case it was the fault of nginx configuration.
    I had told nginx to add a trailing slash at the end of every URL in case it was missing. Gotcha! this was the issue. Hopefully it will help someone.

    Issue explained:
    On submission, the form sends an AJAX request as follows:
    POST
    /wp-json/contact-form-7/v1/contact-forms/1555/feedback

    But my nginx was configured to add a trailing slash. So the response was:
    301 Moved Permanently, with the trailing slash at the end.

    The request gets processed again, but this time, the method is replaced with a GET instead of a POST. (not sure who is at fault here, but it could be: nginx, jquery AJAX, CF7?)

    So the request is replaced with:
    GET
    /wp-json/contact-form-7/v1/contact-forms/1555/feedback/
    Which returns:
    {"code":"rest_no_route","message":"No route was found matching the URL and request method","data":{"status":404}}

    When I changed the WordPress permalinks to plain, everything worked fine.
    I’ve got to find a way to make my permalink work nicely with my nginx configuration.

    I discovered that the rewrite rules were not setup properly.
    I had this in my config:

    # Source: https://www.websavers.org/how-to-speed-up-wordpress/
    rewrite !\.(js|ico|gif|jpg|png|css|pdf|mov|mp3|eot|svg|ttf|woff|otf|txt|swf)$ /index.php break;
    rewrite /wp-admin/$ /wp-admin/index.php break;
    rewrite /$ /index.php break;

    I replaced it with this instead:

    # rewrite rules have to be setup for WordPress
    # https://www.digitalocean.com/community/questions/404-when-using-pretty-permalinks-on-new-wordpress-site-on-lemp-nginx?answer=34928
    if (!-e $request_filename) {
    	rewrite ^.*$ /index.php last;
    }

    Experiencing the same problem with WPML. the form submits okay on my default contact page /contact/ but not on the English version /contact/?lang=en

    fix for wpml: change language to folder structure so it becomes /en/contact/ instead of /contact/?lang=en

    Clement Gonnet – you are right! i’m using apache and had a redirect to so it will always add a trailing slash in my htaccess file. The minute i removed it the issue was solved!

    juslintek

    (@juslintek)

    Having same problems, but my url rules are different. And has no force trailingslash. But I get same error. And I have none of the plugins other mentioned.

    Vadim

    (@vadikcoma)

    Having the same issue here. None of above mentioned tips worked.

    Vadim

    (@vadikcoma)

    I was able to solve this issue by removing “Attach file” field from my form.

    Hi, i have the same problem, i am using a form only with name and email field, does not work:

    /wp-json/contact-form-7/v1/contact-forms/3673/feedback

    {“code”:”rest_no_route”,”message”:”No route was found matching the URL and request method”,”data”:{“status”:404}}

    Please help me

    Please check your web server configuration, it has something to do with slash (/) redirects.

    We had “upload file” field in our form, and it was causing this issue.

    I have only this parameter: RewriteBase /
    The strange thing is that if I use my shortcode in a normal page work, the same shortcode in a custom post gave me the error:

    /wp-json/contact-form-7/v1/contact-forms/3673/feedback

    {“code”:”rest_no_route”,”message”:”No route was found matching the URL and request method”,”data”:{“status”:404}}

    Can somebody help me?
    THANKS

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘My forms is not submitting’ is closed to new replies.