Support » Plugin: Contact Form 7 » My forms is not submitting

  • None of my contact forms are submitting. Whenever I try and submit the form I get this error – “NetworkError: 404 Not Found – website_url/wp-json/contact-form-7/v1/contact-forms/17007/feedback/”

    {“code”:”rest_no_route”,”message”:”No route was found matching the URL and request method”,”data”:{“status”
    :404}}

    The forms were working absolutely fine before but yesterday after we updated the contact form 7 plugin it stopped working. Kindly address this issue asap as this is a very important concern for us.

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Can I see the site?

    Can I have your email id? Still facing the issue whenever the plugin gets updated. Please send me your email id I will be contacting you there.

    Hi @riyabarua

    Did you get a solution? We are having the same issue.

    We have resolved it rolling back to Contact Form 7 v4.7 temporarily.

    @takayukister Any idea why it is not working in the v4.8?

    Thanks

    • This reply was modified 1 year, 10 months ago by  raualvron.
    • This reply was modified 1 year, 10 months ago by  raualvron.

    Hi there. We got the exactly same probleme at https://www.tink.ch/mitmachen. The problem exists since version 4.8. With version 4.7 it works perfectly.

    We also rolled back to version 4.7

    I am having the same issues. I had to roll back to 4.7. I have a multisite. 4.8 works on all the site except one.

    For the one website that doesn’t work, here are the specs:

    I did recently migrate from a DEV to PROD server.
    For The internal domain name, the Contact Form 7 works,
    For The external domain name, which is rewritten by Access Manager (NAM), contact form 7 breaks and I get infinite spinning icon when submitting.

    Development tools:

    {“code”:”rest_no_route”,”message”:”No route was found matching the URL and request method”,”data”:{“status”
    :404}}

    Any help would greatly be appreciated.

    same here!

    rolling back to 4.6.1 did the trick for me to make it work again.

    the issue is imho related to url parameters since
    http://my-life-essence.com/contact/
    is working, but
    http://my-life-essence.com/kontakt/?lang=de
    is not working (leading to a 404 on some ajax feedback page)

    over 2 months have passed since the first report – any news on this?

    You can just add / in feedback route.

    /wp-content/plugins/contact-form-7/includes/js/scripts.js:338

    '/contact-forms/' + wpcf7.getId( $form ) + '/feedback' ),
    –>
    '/contact-forms/' + wpcf7.getId( $form ) + '/feedback/' ),

    meh, i tried but this does not change anything!

    any news from the author?

    Same problems, no solution

    Any news from you guys? author are you there?

    Thanks,
    G.

    is this plugin dead? seems to be updated regularly but not supported here…?

    net

    (@krstarica)

    The same issue with version 4.9.

    net

    (@krstarica)

    Tried 4.9.1, still getting on form submit:

    Uncaught Error: Syntax error, unrecognized expression: {"code":"rest_no_route","message":"No route was found matching the URL and request method","data":{"status":404}}

    Have this issue on one WordPress installation, not the others.

    What could be the reason for this?

    Hi guys,

    I was having the same problem. I’m going to share my solution just in case is useful for someone. In my case the reason was a Regex rewrite rule that I had with the Redirection plugin. The regex was basically mapping an old address to a new one, checking 2 random characters, like this:

    /(\w){2}/(.*)

    This was causing the problem. Now I’m using a more specific regex, giving the letter combinations that i want to handle:

    /(ab|bc|de)/(.*)

    It was having the same issue and the culprit was this plugin
    https://wordpress.org/plugins/cimy-swift-smtp/

    Same issue here @ https://www.war59312.com/contact/

    🙁

    Nothing listed here thus far has made a difference.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘My forms is not submitting’ is closed to new replies.