Support » Fixing WordPress » My footer background image is floating under header in IE??

  • [ Moderator Note: Please post code or markup snippets between backticks or use the code button. Or better still – use the pastebin ]

    So most of the footer loads properly in the right place .. just not #footer-bott, the image floats under the header??

    Here is the CSS:

    #footer-bott {
    padding: 15px 0 0 0;
    margin: 0 auto;
    width: 100%;
    height: 295px;
    background: #bcc5c1 url('images/footerbar.jpg') top center no-repeat;
    clear: both;
    color: #fff;
    font-size: 1.1em;
    }

    Here is the coding in footer.php

    <div class="blogroll-foot">
    
    <!-- begin widgetized footer -->
    
    <?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Footer Middle') ) : ?>
    <H4 class="footerwidget">Blog Roll</H4>
    <?php
    $links = wp_list_bookmarks('title_li=&categorize=0&sort_column=menu_order&echo=0');
    $bookmarks = explode('', $links);
    $links = $bookmarks;
    $link_n = count($links) - 1;
    for ($i=0;$i<$link_n;$i++):
    if ($i<$link_n/2):
    $left = $left.''.$links[$i].'';
    elseif ($i>=$link_n/2):
    $right = $right.''.$links[$i].'';
    endif;
    endfor;
    ?>
    <ul class="left_blogroll">
    <?php echo $left;?>
    
    <ul class="right_blogroll">
    <?php echo $right;?>
    
    <?php endif; ?>
    
    <!-- end widgetized footer -->
    
    </div>
    
    <!-- begin widgetized footer right -->
    
    <div class="recent-foot">
    <div class="getintouch">
    <?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('Footer Right') ) : ?>
    <H4 class="footerwidget">Recent Comments</H4>
    <?php
    global $wpdb;
    $sql = "SELECT DISTINCT ID, post_title, post_password, comment_ID, comment_post_ID, comment_author, comment_date_gmt, comment_approved, comment_type,comment_author_url, SUBSTRING(comment_content,1,30) AS com_excerpt FROM $wpdb->comments LEFT OUTER JOIN $wpdb->posts ON ($wpdb->comments.comment_post_ID = $wpdb->posts.ID) WHERE comment_approved = '1' AND comment_type = '' AND post_password = '' ORDER BY comment_date_gmt DESC LIMIT 10";
    
    $comments = $wpdb->get_results($sql);
    $output = $pre_HTML;
    $output .= "\n
    
    ";
    foreach ($comments as $comment) {
    $output .= "\n
    ".strip_tags($comment->comment_author) .": " . "ID)."#comment-" . $comment->comment_ID . "\" title=\"on ".$comment->post_title . "\">" . strip_tags(substr($comment->com_excerpt,0,20))."
    ";
    }
    $output .= "\n
    ";
    $output .= $post_HTML;
    echo $output;
    ?>
    <!-- end widgetized footer right -->
    <?php endif; ?>
    </div></div>
    
    </div>
    </div>
    
    <div class="footerlinks">
    
    /">Home   |
    <?php
    $links = get_pages('number=6&sort_column=post_date&depth=1&title_li=');
    foreach($links as $i => $page)
    $links[$i] = ' ID) . '" title="' . attribute_escape(apply_filters('the_title', $page->post_title)) . '">' . apply_filters('the_title', $page->post_title) . '';
    echo implode('  |  ', $links);
    ?>
    
    </div>
    </div>
    
    <div id="footer-bott"><center>© 2012 <?php bloginfo('name'); ?>. All Rights Reserved. </center</div>
    
    <?php echo get_option("greyzed_analytics"); ?>
    <?php wp_footer(); ?>
    </body>

    And here is the code in page.php calling on footer:

    …..

    <span>Email</span>
    
    </div>-->
    
    <?php comments_template(); ?>
    
    </div>
    
    <?php endwhile; endif; ?>
    <?php edit_post_link('Edit this entry.', '<p>', '</p>'); ?>
    
    </div>
    
    </div>
    <?php get_footer(); ?>
    
    <?php get_footer(); ?>

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator: Why would you close my other thread? It actually had responses!? Thanks. Should have closed this one and left other one open.

    Have you defined the correct HTML type in the header of the document. I know IE likes to see this and it can cause issues with CSS if you do not define it.

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>
    <head profile="http://gmpg.org/xfn/11">
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />

    The only thing I can think of is maybe something is happening when I “clear both” in the css….

    Michael

    (@alchymyth)

    Forum Moderator

    usually, the duplicate (newer) topic will get closed.

    simply do not start more than one topic per problem;
    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

    Lovely, I still need this fixed. No one? I fixed all mark up related to the footer, tried a couple different clear: both work arounds…

    Can’t figure this one out. Need a wizard.

    Removed said div until I can find a work around …

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘My footer background image is floating under header in IE??’ is closed to new replies.