WordPress.org

Support

Support » Installation » My domain points to Index

My domain points to Index

  • When you point a browser at my site you get a page called index that lists a bunch of files including wordpress. When you point the browser at http://www.example.com/wordpress you get my front page but none of my post pages work, you just get the same index of page.
    Thanks for any ideas you may have. Also, I am new to this and am still learning how everything works, so I am confident that the answer to this question is fairly simple but still appreciate the help as I have spent considerable time trying to figure it out with no luck.
    Thanks.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Have a look at url settings in admin, also check out permalinks .Your posts are possibly mysite.com/wordpress/p=id

    Thank you for your reply, I appreciate it. I have looked around and am not sure what I need to check out/what I need to do, so if it’s not too much trouble, I will provide more information based on your post (hopefully that will help).

    Sample Page in WordPress has a permalink of Permalink: http://www.example.com/
    It is my front page (referenced in original post), the sample page is the one page I have access to once I point to example.com/wordpress (example.com takes me to index page, so do all menu pages other than the sample page).

    The other pages that I have created have permalinks that look like this Permalink: http://www.example.com/?page_id=28
    (when I click on those pages I am taken to index)

    My WordPress Address (URL) is http://www.example.com/wordpress

    My Site Address (URL) is http://www.example.com

    Sorry, as I mentioned before, I am in the beginner stage of this but am working hard to pick it up and eventually get good. Thanks in advance for any advice you may have.

    try your address/folder?/page_id=28

    I’m sorry, but try it where?

    If your wordpress address is your site/wordpress then try yoursite/wordpress/your page id or what happens with yoursite.com/yourpage
    also check out your cp first you may get a better idea there about your structure.

    http://www.example.com/?page_id=28 points to the index.

    what is a cp?

    Control panel from your host, you are very close keep at it . What is your url?

    http://www.davidbrownelawfirm.com. My host is dreamhost. Before using the forum I found people who seemed to have at least a somewhat similar problem who were able to fix their after moving (or manipulating) the index.php file. My index.php file is contained in the wordpress folder, which is a subfolder of davidbrownelawfirm folder. If I point to http://www.davidbrownelawfirm.com/wordpress, I get the homepage (but the other pages contained on that homepage point back to the index). If I point to http://www.davidbrownelawfirm.com, I get the index.
    I password protected both davidbrownelawfirm and davidbrownelawfirm/wordpress by using Htaccess/WebDAV toolbar in Dreamhost. If it makes it easier to figure out how to fix, I can get rid of password protection.
    Thanks again for your help.

    My index.php file is contained in the wordpress folder, which is a subfolder of davidbrownelawfirm folder.

    I’m a bit confused on this one, your index should be in the root. Perhaps I am not reading this correctly, it’s early am here.
    I’m asked for a db password which, if I am correct indicates index is in the wrong folder

    My guess is that I wasn’t explaining correctly. Still learning this stuff. Good news is that with your help I figured out most of the problem (with one new added unwanted wrinkle).

    The following accurately describes the problem I had. http://wordpress.org/support/topic/my-domain-points-to-an-index-of-page?replies=3.
    Specifically, this part “Now when you point a browser at my site you get a page called index of that list a bunch on file including wordpress. when you point the browser at http://www.example.com/wordpress you get my front page but none of my post pages work, you just get the same index of page.”

    That guy solved his problem by “moving all the files from public_html/wordpress into the folder public_html.” I tried a similar move and moved all files and folders from the davidbrownelawfirm.com/wordpress folder to the davidbrownelawfirm.com folder. After doing that, I was unable to login but was able to change URL in database from http://www.davidbrownelawfirm.com/wordpress to http://www.davidbrownelawfirm.com. That fixed the login problem

    Now everything seems to be in order except for one detail that I can’t figure out for the life of me. When I direct to http://www.davidbrownelawfirm.com the entire page layout is there, including the menue tabs, however, both the homepage and menu tabs if you click on them state “404: Page not found. We are terribly sorry, but the URL you typed no longer exists. It might have been moved or deleted, or perhaps you mistyped it.” When I login to wordpress, that error message disappears and I am able to see content of all pages.

    since you changed the urls and moved your wordpress from wordpress folder to root you need to reset your permalinks in Settings>>>Reading.

    I think you have programmed your site in such a way that even search engines cannot crawl or index your site. Is it a personal and private site which is open to only you and your near and dear ones?

    If you need folk to see the site to offer help, you need to make it publicly accessible. You may need to go to the admin’s Settings -> General and set the site annd WordPress URLs.

    Your nearly there, Just as an absolute You can login ?,Your wp site appears ?,When you click tabs you get 404’s. This relates to the move to/from subfolder you can set a rewrite rule to sort this.However you should look at permalink structure first.This may not resolve it. If you have a small amount of content.I would encourage you to set up permalinks in the manner you would like .i.e. /%postname%/%date%/Try a test post/page and see how it works. Then you can move content from old pages (db) to new or use rewrite in .htaccess or search plugins.
    Incidentally wp will work from any folder/subdolder, proviso being all are at the same location.

    Krishna looks like http://www.davidbrownelawfirm.com root directory is password protected from the host.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘My domain points to Index’ is closed to new replies.