WordPress.org

Support

Support » How-To and Troubleshooting » My Blog is missing any buttons

My Blog is missing any buttons

  • I have WordPress all set up, can log in, and go to my blog by opening localhost/wp.php in IE.
    But there are none of the buttons that are described here –
    For instance, “Now it’s time to start writing! Click on the ‘Write’ Menu option. What’s displayed is your Editing Area (follow that link for a more complete description of what’s shown). “
    I have no menu, much less a Write option.
    This is tantalizing. Please help a totally new and confused blogger. (My blog is set up on my own pc, not on the web).

Viewing 12 replies - 1 through 12 (of 12 total)
  • Didn’t mean to be anonymous.

    A few more details about my setup.
    Apache 2
    MySql 4
    PHP
    All running on my own PC.
    All the wordpress files and subdirectories have been copied into C:\Program Files\Apache Group\Apache2\htdocs

    I log in to my WordPress as admin with the assigned password – but with no menu or options, I can’t do a thing.

    opening localhost/wp.php ?
    wp-login.php should take you to wp-admin/wp-post.php

    Ah! Thank you, podz.
    It doesn’t exactly take me anywhere – “Back to my blog” takes me to my index.html.
    You lead me to think that WordPress doesn’t know where to find its files. When I downloaded it I installed it in C:\wordpress, but the working files are in C:\Program Files\Apache Group\Apache2\htdocs.
    I’m away from home right now, but when I get home I’m going to try to figure out how and where it sets its base directory, and if necessary I will reinstall it.

    Check the wp_options table – that is where site_url is set.

    Hmmm. I don’t remember much SQL, so rather than create a query, I dropped the wordpress database, then re-created it, and flushed it.
    Then I ran localhost/wp-admin/install.php.
    When it asked for the host, it had guessed http://localhost. I left that.
    It completed the installation with no problem.
    Then I logged in as admin.
    It still didn’t take me to wp-admin/post.php.
    It took me to “Index of /wp-admin”, where the url in the address bar was http://localhost/wp-admin/
    I had removed all WordPress files that weren’t in C:\Program Files\Apache Group\Apache2\htdocs. That didn’t help.
    Desperation is setting in. I’m going to unzip the wordpress-1.2-mingus.zip again.
    What could the trouble be?

    That Anonymous was me.

    Is it possible that WordPress is not compatible with Apache 2?
    Should I install Apache 1?

    I’ve now experimented with various locations for the wordpress files.
    C:\
    C:\wordpress
    changing the Apache DocumentRoot each time, and doing a clean reinstall each time.
    It makes no difference, the result is always the same. Log in as admin, it takes me to index of /wp-admin
    If I open http://localhost/index.php then I get a blog page, but with no menu.
    I’m defeated.

    I now think the problem may be in wp-login.php
    if (0 == $user->user_level) {
    $redirect_to = get_settings(‘siteurl’) . ‘/wp-admin/profile.php’;
    }
    It seems possible that the ‘admin’ user isn’t getting $user->user_level set to 0.
    This evening I’m going to try a few hacks.

    I solved this. Stupid user error.
    I thought /wp-admin/wp-admin/ was an unzipping error (as does sometimes happen).
    So I deleted the nested wp-admin folder without bothering to look what was in it.
    Of course, what was in it was essentially the whole blog gui. 🙁

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘My Blog is missing any buttons’ is closed to new replies.
Skip to toolbar