Support » Installing WordPress » My blog is being redirected to the main website

  • Resolved gideon625

    (@gideon625)


    I installed word press through the set up provided by my hosting server and everything went fine and dandy. Because I’ve never used WordPress and I am new to blogging, I was looking through the settings within the blog after it was installed. Last I remember, I was looking at the Manage-Files tab, changed some text in one of the header sheet, trying to make it smaller, and next thing I know, something is totally messed up. See it for yourself at http://www.musicbasix.com/blog.

    I saved the blog page to my desktop, and instead of having a stylesheet saved, I got an a file named ‘a’???

    Any help out there?!

Viewing 4 replies - 1 through 4 (of 4 total)
  • For the future: never mess around (meaning don’t use!) the online file and theme editor – they don’t have an “undo” button. Especially, don’t use it if you don’t know what are you doing.
    Next, you don’t save the “blog page” to your desktop. If you want to edit them, use a ftp client, download them, open in a plain text editor and edit.
    Upload when done.
    To fix it: upload a fresh copy of the theme’s files that you screwed up.

    I normally do all my editing in with a text editor and upload to the FTP.

    I only saved it to my desktop because I did a second install at http://www.musicbasix.com/blog2 to try and compare what went wrong, and the first thing I could think of was to save a local copy to see what copied and compare any differences, since I compared and compared between the two FTP folders /blog, and /blog2.

    I uploaded the following folders, clean files: wp-admin, wp-content, wp-includes.

    None of these fixed the problem. Any other ideas out there?

    Under Options -> General, there are two URL values. They need to be “real”. Did you change ’em to not match your where your blog is?

    If you can’t login to check, this tutorial may be helpful: http://www.tamba2.org.uk/wordpress/site-url/

    HandySolo,

    I am pretty sure I didn’t change the url’s, at least not on purpose, and especially not consciously to that weird ‘blog/?page…’

    I couldn’t log in to my blog, so I followed the steps you gave me and voila! Thanks A MILLION for your input and the link you provided showing me how to access through the myPHPadmin. It worked like a charm and it was very simple to follow.

    I love mistakes, you always learn so much from them!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘My blog is being redirected to the main website’ is closed to new replies.