WordPress.org

Forums

My Blog Dissapeared - Urgent Help Needed! (9 posts)

  1. cudjoe
    Member
    Posted 6 years ago #

    Hello,

    I recently tried to post to my blog, and HORROR, no blog anymore. I don't know what is the problem.

    If it was a new blog, I wouldn't mind, but it's more than two years with hundreds of posts. Plus I am going to lose my rankings on Google.

    Please , let me know what I can do?

    Here is the link to my blog:

    http://mynetmarketingland.com/blog

    Plus here is what my webmaster replied to me:

    "It appears that someone wiped your database (older versions of wordpress are known to have security holes and that's why you should always keep it up to date). The only solution would be to re-install the wordpress software."

    What I can do?

  2. unixgolf
    Member
    Posted 6 years ago #

    Looks like your best course would be to reinstall and restore from your most recent backup.

  3. cudjoe
    Member
    Posted 6 years ago #

    Thanks a lot mate.

    Where can I find my latest backup?

    I did one and saved it on my laptop, but my windows system recently crashed.

    Can I retrieve a backup from my hosting?

    Thanks for help,

    Franck

  4. cudjoe
    Member
    Posted 6 years ago #

    I think that there is nothing to do...

    Look at what my webmaster just sent me:

    --------
    I'm afraid that you've lost the blogs - I checked the backup drive but the copies have been overwritten with the blank dbs.

    You can re-install the software through your hosting account's control panel. Use the "Fantastico" feature and you'll be able to install the latest version of wordpress on your account.
    --------

    Is there a last thing to do? Or there is no hope

    Franck

  5. cudjoe
    Member
    Posted 6 years ago #

    Update, I tried to reinstall a blog on my subfolder, but I can't.

    Here is the message I get:

    Install WordPress (2/3)

    The installation can not be completed:

    - This directory already exists or the directory field is empty

    Click on the browser's Back button to fix reported errors.

    Please help.

    Franck

  6. moshu
    Member
    Posted 6 years ago #

    You could still ask your host if they make backups - some (the good ones) do, Even if it is, let's say, one month old, it would be still better than nothing...

    So, did you try to install it in an existing folder? That's what it is complaining about...

    On the other hand, you can safely do a manual install:
    Installing_WordPress#Detailed_Instructions

    (despite what your "webmaster" says... Fantastico is never installing the latest version!

  7. cudjoe
    Member
    Posted 6 years ago #

    Thanks moshu,

    I tried to reinstall a new one in the older folder (and the old one is still there...).

    Here is what he said about the backup:

    "I'm afraid that you've lost the blogs - I checked the backup drive but the copies have been overwritten with the blank dbs."

    Does this means that there is not a single backup?

    Franck

  8. moshu
    Member
    Posted 6 years ago #

    Is that an answer from your "webmaster" or from your host? (FYI: your host is not your webmaster; your webmaster should be the guy whom you hire to prevent you to get again in a similar situation :)

    Well, if nobody made ever any backup... or saved it from the server... not much hope there.

  9. cudjoe
    Member
    Posted 6 years ago #

    Sorry moshu,

    In fact, my webmaster is my host...

    I'll ask him if he made a backup before... If not, I will start over with a brand new (and better) blog.

    Thank you for your support moshu.

    Franck.

Topic Closed

This topic has been closed to new replies.

About this Topic