Support » Installing WordPress » my attempt to 1.2 to 1.5 upgrade

  • I’ve read the rest of the posts on upgrade/install, but I must be missing something.

    I used cpanel/fantastico to install 1.2 in a new sub-domain. new mysql database, etc.

    but your dns may not see it yet.

    I checked and it all worked, able to login, configure viewing and posting, etc.

    I followed the page mentioned by podz, not the old upgrade page.

    I edited wp-config-sample.php and changed its name to wp-config.php

    added the info below

    define(‘DB_NAME’, ‘drivein_wrdp6’); // The name of the database
    define(‘DB_USER’, ‘drivein_wrdp6’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘leavingthisout’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    and went to wp-admin/upgrade.php

    Says it cannot connect to host.

    I double checked by compariing it to my other wp-config.php files for my other blogs.

    It is the same except for different users and the password is different. They have ‘localhost’ as well and they work.

    I did try in more than one browser to make sure the cached ‘cannot connect’ page wasn’t coming up that way.

    Any suggestions ?


    edit: nothing in the database. This is all a brand new install.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hmm. I copy and pasted the lines above from another wp-config.php file, and when I try to connect to poetry.drivein, it now works.

    So evidently… its just that bit that differs between poetry’s wp-config.php and the other blog’s wp-config.php

    Didn’t work when I changed it back to drivein-wrdp6 and changed the password in phpmyadmin.

    I’m lost.




    First guess would be that the user does not have permissions/access rights to the database.


    I created the whole thing, even used the phpmyadmin thing to change the password. md5, then copied the result to the wp-config.php file. No go.

    Oh, the ‘paste info from another blog, isn’t connecting to the poetry blog, but to the other blog.

    I may just roll it all back to 1.2 if it wont work otherwise.

    When I upgraded, on my other blogs, from 1.2 to 1.2.2 it worked.

    I know I can do that…

    Well, I am going to try a ‘from scratch’ install of 1.5 I was able to uninstall the entire thing. So I am going to redownload 1.5 and use the ‘first install’ info.

    I have another few hours to try various things, I work this weekend, so I’ll have to get sleep sometime. 🙂

    I don’t know what I broke earlier…

    but 1.5 is working for me now.

    I realized, after all was said and done…, I could have saved myself some trouble.

    By taking the config.php file the fantastico install placed in the sub-domain, and backed it up to floppy or my hard drive.

    All of the correct mysql info would have been in there.

    Instead… I wrote over it. Causing myself several hours of headaches when I broke the upgrade.

    Live and learn.

    Site is up, got GreenTrack theme but I changed the pic to some reflection nebula around a couple of stars in Ophichus constellation.

    alot of it will be sf poetry anywho.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘my attempt to 1.2 to 1.5 upgrade’ is closed to new replies.