[resolved] 'My Account' Page stopped working after upgrade (13 posts)

  1. Sharebear19
    Posted 3 years ago #

    Hi I set put the links for the My Account page on my page months ago and it was working fine until I did an upgrade last week.

    here is the URL: http://www.heelmebaby.com
    Top Right corner= 'Log In'
    Footer= 'My Account'

    When I click on the My Account page it won't even load up.

    I don't want to have to delete and redownload the plugin again.

    What can I do to resolve this issue?

    Thanks your your help


  2. Nabha
    Posted 3 years ago #

    Do you get any errors?

    Customer accounts have been getting a redirect loop error on that same page, when I check "Prevent customers from accessing the WordPress admin" in the WooCommerce settings page.

    In Chrome, I see:
    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

    It looks like the My Account page is trying to redirect to the profile page for some reason. This doesn't happen with my admin account.

  3. Nabha
    Posted 3 years ago #

    OK, for me it happened because the password wasn't properly set for the new account -- even though I had typed it in, in the checkout process. That's another bug to figure out, of course, but at least it sheds some light on what is going on.

  4. Nabha
    Posted 3 years ago #

    Aha -- I was using Force Password Change, which made sense in an earlier incarnation of the site.

    Sorry Sharebear, that probably isn't any help -- but try providing whatever error message you are getting, maybe that would help people answer with the possible next steps for you.

  5. Sharebear19
    Posted 3 years ago #

    Thanks Nabha for your posts!

    Yes I get that same error message that pertains to redirects. When I click on the link in Safari the search bar takes long to load and has the redirect message and then the Safari page says cannot open the page.

    I re-downloaded the program in hopes that I could make it work, but it's still occurring. I will try out your method and see if it works.

    I tried purchasing a product too and now the 'My Checkout' page doesn't work either.

    oh man. I wouldn't know where to start to change the code.

  6. Sharebear19
    Posted 3 years ago #

    I have a multinetwork wordpress dashboard, if that helps. One wordpress site with woocommerce set-up and the other as a blog.

    the shortcode is put in correct on each page.

    even the wpadmin page is re-directed

  7. Nabha
    Posted 3 years ago #

    For a lot of people it has to do with plugin conflicts (as it did for me). You might explore that if you have any security plugins or SSL plugins.

    Otherwise, it would be worth playing around with WooCommerce's SSL settings on the General tab of the Settings page. Disable "Force SSL" or "Un-force SSL" for a moment to see if it fixes the problem.

    Generally of course you WOULD want to force SSL to be on for checkout, because otherwise people might be sending you credit card info in an unsecure way.

  8. Sharebear19
    Posted 3 years ago #

    Thanks Nabha for helping me come to understanding of why this has occurred.

    I know now that it's a multisite issue. I manually recreated the account and checkout page and added the short code. That solved the redirect problem.

    Now I have another issue to attend to: the pages won't connect to the woocommerce pages system.

    I add the pages to the system and when i click on the button the page won't load up.
    I wil read on to see if other multisite users have had this issue, and then repost as a separate issue if not.

  9. flyersfan48
    Posted 3 years ago #

    Did you try nabha's suggestion? That got it to work for me

  10. Sharebear19
    Posted 3 years ago #

    Thanks flyersfan and Nabha. I went back to the page again and the box was still checked. It seems to work fine now after I unchecked the ssl. but you're right nabha im still going to need some ssl for ecommerce transactions.

  11. acesj
    Posted 3 years ago #

    redirects sound like a .access issue. Trying clearing your .access or rewrites and start over.. Some web host put these files as hidden in cpanel and hhost .. These can be found through wiget or pcfc.

    Vhosts and linix I have found create files with in certain web hosts.
    As they do a server update the file appears..

    Most common is 303
    and the worst 404

    Just make sure you have no un intentional code in your .access / phpini files

  12. Sebastien Dumont
    Posted 3 years ago #

    I updated WooCommerce today after leaving it on the last version of 1.6 to the latest 2.0.10 and now I can not access My Account page or anything under it.

    Also the menu link to the page does not show unless logged in as the administrator.

    Does this only occur in the last build? Has any one gone back a version to see if this problem still exists ?

    I don't have SSL enabled on my site.

    Do I also need to allow users access to WordPress control panel as normal by removing the redirect ?

    If any one has any answers to any of those questions please let me know.

    Thank you.

  13. toddmcm
    Posted 2 years ago #

    The fact that there is no answer after 10 months is absurd.

    I have no answer, but also have this issue as of the last update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic