Support » Plugin: Collapse-O-Matic » Mutiple html tags in title

Viewing 13 replies - 1 through 13 (of 13 total)
  • Pryhn

    (@pryhn)

    Oups my question didn’t show up like I taught it would.

    How can I put a «HTML tag» on a specific word in a title.

    Something like this: ‘[expand title=”Exemple<sup>word</sup>”]’

    But this method doesn’t work, my title disappear.

    Plugin Author Baden

    (@baden03)

    We did the following and it works on our test server:

    [expand title="Example <sup>word</sup>" tag="div"]this is a test, nothing to see here.[/expand]

    Can you provide a link to your page, maybe there is a css issue.

    Pryhn

    (@pryhn)

    Hi!

    It doesn’t work!
    I paste your code on this page so you can see what happen. The title disappear. http://www.omnikin.com/construction/test-colapse-o-matic/?lang=en

    thanks

    Plugin Author Baden

    (@baden03)

    Hello. The HTML being generated on your site is as follows:

    <div class="collapseomatic  colomat-visited" id="id5086" title="Example <sup>word</sup>“>Example <sup>word</sup></div>
    <div id=" target-id5086"="">this is a test, nothing to see here.</div>

    Make sure you are editing in Text/HTML editor, not the Visual editor.
    Look and make sure there are no tags.

    There is something simply going on, should be an easy fix.

    Pryhn

    (@pryhn)

    Ok !

    I’am not sure to understand what you mean!
    I simply paste this
    [expand title="Example <sup>word</sup>" tag="div"]this is a test, nothing to see here.[/expand]
    in Text/HTML editor and publish?

    Thanks for your help !

    Plugin Author Baden

    (@baden03)

    When you edit a post or page, you have the option of editing in Visual mode or Text / HTML mode. The text mode will allow you to see all of the actual html code. Good to make sure no funny business is going on.

    so yes, just open up the post, switch to Text mode and paste the code. You might notice when you switch to text mode that what you pasted in visual has a bunch of nasty stuff. When you paste in text mode, you only paste the actual code… no fancy formatting.

    Good Luck!

    Pryhn

    (@pryhn)

    Yes I know those things.

    I pasted the code in the Text/HTML but it doesn’t work even my code is clean! So the source of the problem is something else ! Maybe my theme ?

    Plugin Author Baden

    (@baden03)

    I still see a fancy quote, not a standard double quote in your closing title attribute.
    Try replacing all ” with ‘ and see if that helps. Something is jacking with your code.

    Pryhn

    (@pryhn)

    🙁
    Still doesn’t work!
    So I think I’m gonna write my title without the tag I wanted !

    Plugin Author Baden

    (@baden03)

    Please contact us at support [at] twinpictures [dot] de and we will try and help you offline. Something is very wonky with your setup.

    Plugin Author Baden

    (@baden03)

    OK, we took a look, and there is either a plugin or theme function that is messing with how shortcodes are being processed. What you can do to FORCE it to work correctly is wrap the shortcode in a [raw] tag like so:

    [raw][expand title="That is how the <sup>seahorse</sup> do"]this is a test, nothing to see here.[/expand][/raw]

    Strange… but it seems to work.

    Pryhn

    (@pryhn)

    Thanks you so much for your very efficient and fast help!

    Plugin Author Baden

    (@baden03)

    It’s how we do 🙂 If you like, please vote for pedro!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Mutiple html tags in title’ is closed to new replies.