WordPress.org

Forums

Post By Email
"Must wait 5 minutes" (5 posts)

  1. etrnldarkness
    Member
    Posted 1 year ago #

    I originally was trying this one 3.7.1 but upgraded to 3.8 and am having the same issues today.

    Alright so here is the story!

    I was trying to get this plugin to work with my gmail to no avail. Gmail was blocking it's connections for security purposes (even though I enabled imap etc). I kept getting failures to connect for this reason.

    So I tried an old yahoo account. IT WORKED! Like a charm!

    I set up a new yahoo account for the website (it's not my website, don't want it using my email!). It wouldn't work. I would get a blank page when I'd try to "check now" and then I'd refresh and click "check now" again and be told to wait five minutes. I'd wait...sometimes a couple hours...try again, same issue.

    I enabled SSL on that yahoo account and checked all the options between the one which worked and the one which didn't - everything was identical. I'd still get the 5 minute error. Even though the program is set to run every hour, I'd see no logs that it tried. (Let it sit over a day).

    For kicks all I did was alter the login info to my old yahoo account and it was picking up posts, switched it to the new yahoo info and no dice.

    Alright, so onto outlook. Figured maybe it was something in the 'new' yahoo mail since my last older one is years older. I created an outlook email. I enabled the pop3 (imap didn't seem to be allowed) and configured everything exactly how outlook said to.

    I am getting the same 5 minute warning. I did change wp_debug to true and tried that. When I did this, it caused an error on the server (showed up at the top of the page) and whenever I tried to click "check now" it was just keep trying and would timeout, with no log showing. So I put it back to false and tried again. Same issue - blank page (or time out), refresh, click again and 5 minute error.

    I let it sit for a few hours and even though it was set to check automatically twice since then, nothing shows up in the logs to show it actually tried. ;(

    Thank you for any help you can give me!

    http://wordpress.org/plugins/post-by-email/

  2. Kat Hagan
    Member
    Plugin Author

    Posted 1 year ago #

    What was the error that showed up at the top of the page? (The blank page is simply how WP "handles" the error when WP_DEBUG is turned off.)

  3. etrnldarkness
    Member
    Posted 1 year ago #

    Hi Kat,

    Thank you for the speedy response!

    When using the current theme, if I set WP_DEBUG to "true" I get the following error

    Deprecated: Assigning the return value of new by reference is deprecated in /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php on line 302

    I see that when in the dashboard while making the change.

    If I log out I see all this:

    Deprecated: Assigning the return value of new by reference is deprecated in /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php on line 302

    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-login.php on line 415
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-login.php on line 427
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 695
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 696
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 697
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 698
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 699
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 700
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 703
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 704
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 705
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 706
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 709
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 710
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 711
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 712
    
    Warning: Cannot modify header information - headers already sent by (output started at /home4/odin/public_html/skyviking.net/svwp/wp-content/themes/travel-blogger/lib/functions/layout.php:302) in /home4/odin/public_html/skyviking.net/svwp/wp-includes/pluggable.php on line 896

    And cannot log in until I put it back to "false"

    I don't think this theme I am using liked turning the debugging off :D

    I did forget to mention - in our previous theme while I was having issues in the beginning I tried the debugging technique and I got no error with that theme, but the email still would not work.

    It's so odd!

  4. Kat Hagan
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm. Do you happen to know what version of PHP you're using? If you're on 5.2, upgrading to at least 5.3 might fix this issue.

  5. etrnldarkness
    Member
    Posted 1 year ago #

    Hi Kat,

    Thank you for responding. The client just got back to me. :)

    Their PHP version is 5.2.17 so I guess we will have to have the host emailed and asked :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Post By Email
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.