WordPress.org

Forums

WP Smush
[resolved] "must be within the content directory " (17 posts)

  1. houmaan
    Member
    Posted 2 years ago #

    Hi

    I try to use this plugin but I always get the error saying "...must be within the content directory ...". My share host is Windows based.
    I am updated to the latest version o fWP and Smush.it plugin.

    Thanks,

    http://wordpress.org/extend/plugins/wp-smushit/

  2. tom.eagles
    Member
    Posted 2 years ago #

    Hello there. The plugin is currently being rebuilt.
    Until that is finished I would suggest you use a previous version.
    To do so you can simply go here and download version 1.6.2 until this issue is resolved.

    Thanks!

  3. houmaan
    Member
    Posted 2 years ago #

    Hi

    Where can I download 1.6.2?

    Thanks,

  4. Aristeides Stathopoulos
    PressCodes
    Posted 2 years ago #

    Hello there!
    You can download previous versions from here: http://wordpress.org/extend/plugins/wp-smushit/developers/

    Cheers,
    Ari.

  5. houmaan
    Member
    Posted 2 years ago #

    Hi

    Still getting same error :(
    Isn't it due to Win NT server?

    Thanks,
    Houmaan

  6. tom.eagles
    Member
    Posted 2 years ago #

    @houmaan

    let me get back to our team and get a definitive answer on this for you.

    Cheers

    Tom

  7. kja79a
    Member
    Posted 2 years ago #

    I'm having the same issue on a NT machine as well and thought this might help narrow down the issue...

    In my case the error message is referring to the path "E:inetpubvs239227/wp-content/uploads/2013/04/...."

    There is a / missing between "E:inetpub" and "vs239227", so the correct path to my uploads should be "E:inetpub/vs239227/wp-content/uploads/2013/04/...."

    Could the invalid path value be causing the plugin/API to give these errors?

  8. Mike
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hi @houmaan & @kja79a

    Sorry about the delay here, but a few days ago one of our developers officially took over WP Smush.it and has just released version 1.6.5.1 which addresses a few problems including this one.

    Could you both try it out and see how it does?

  9. kja79a
    Member
    Posted 1 year ago #

    Thanks Mike.
    I'll give it a try and let you know.

    I also realised in my previous reply that there were TWO missing slashes "/" in the invalid path, which should have read "E:/inetpub/vs239227/wp-content/uploads/2013/04/...."

    Or perhaps all the forward slashes should be backslashes for the Windows path??

  10. Mike
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hi @kja79a

    I'm afraid I don't know how it should be on a Windows server, however I do know that 1.6.5.1 addresses paths so this may well be fixed.

    Please let us know how your testing goes.

  11. houmaan
    Member
    Posted 1 year ago #

    Hi @Mike,

    Updated but still get same error.
    Thanks,

  12. Mike
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hi @houmaan

    Ok thanks for reporting back, I've notified the developer to see if he can look into this.

    Thanks!

  13. kja79a
    Member
    Posted 1 year ago #

    @Mike,
    No luck for me either, still the same error message with the same problem of missing slashes in the file path.

  14. Mike
    WPMU DEV Support Staff
    Posted 1 year ago #

    @kja79a

    Ok thank you, this will be a hard one to fix as the developer doesn't have a windows server to test on. So he can only try things, and we'll need people like yourself to test if that's ok :-)

  15. Can either of you try this beta of 1.6.5.2, it should fix the path issues. and report back.

    https://dl.dropboxusercontent.com/u/2616987/WPMUDev/wp-smushit/wp-smushit-1.6.5.2-Beta1.zip

    Thanks.

  16. houmaan
    Member
    Posted 1 year ago #

    The problem is solved to some extend. Means that I do not get the same error message but it could not smush all my images. Simply the connection is restarted! My website is photography website and I have lots of images. I found out it smushed some on the top of the list but not all the images.

    Thanks.

  17. @houmaan,

    Well, The Yahoo! service limits files no larger than 1Mb. You've not provided any specific details so I'll stop guessing there as to why the other images are not processed.

    And I've not sure on your comment "Simply the connection is restarted!" Basically, each image is process individually. Meaning via the API call we can only pass a single image URL. The plugin just calls the API for each image to be processed. Again this is a limitation on the Yahoo! Smush.it service not the plugin.

    On the unprocessed images try going to Media > Library. Find an image that has NOT been processed. Set the checkbox for that item row. Then from the Bulk Actions dropdown select the 'Bulk Smush.it' then click the Apply button. This will process that one image.

    The difference between doing this and simply clicking the 'Re-smush' on the row is doing this via the checkbox will show the processing output where as the 'Re-smush' just returns to the Media listing screen. So you are not able to see any errors.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Smush
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags