Support » Plugin: Agora Video for WordPress » Must be Something Wrong

  • Resolved imkosmic

    (@imkosmic)


    I’ve followed the quick install guide, have my App ID and App Certificate, but when using the shortcode [agora-communication channel_id=”8″], the page shows the interface, but nothing happens except to show a microphone, webcam and ‘hangup’ button.

    Am I missing something?

Viewing 13 replies - 16 through 28 (of 28 total)
  • Thank you for answer, I just created a new project on Agora, at beginning without App certificate, then enabled the App certificate for the project and copyed to wordpress setting, then I created a new channel on wordpress but I have the same problem.
    I think there is something wrong when I create the app certificate?

    Thank you, Marco

    Hi thank you for your reply.
    I am using verison 1.5.
    I have set the App Id and pasted the certificate details in my Worpdress Settings Page.
    As soon as I update the page the settigns for the certificate disapears?

    Plugin Contributor hermesf

    (@hermesf)

    @louisferr We recently made a change to the plugin to resolve plugin conflict issues, and this sounds like a similar behavior. Do any of the other values fail to save?

    @mfjunior74 can you confirm whether your App ID and App Certificate values are properly being saved in the Agora Video For WordPress Settings page.

    Dear @hermesf, I see that I can save the App ID and App Certificate, but if i refers the page the App ID and App Certificate are not maintained.

    Plugin Contributor hermesf

    (@hermesf)

    @mfjunior74 @louisferr The team has prepared a hot-fix, but I want to confirm that it is resolves your issues before pushing it out to the rest of the users. Please download the “Development” version of the plugin from the Advanced View (https://wordpress.org/plugins/wp-agora-io/advanced/), the plugin download is at the bottom of the page. Once you download, please manually install it through your plugins page.

    Hi Thank you, I have updated the plugin to the developer one – the new plugin has accepted the certificate. It keeps the information now. But the video still doesn’t work.

    As a side note I tried changing the button colours, the changes didn’t reflect live?
    Thanks

    Here is the console:

    JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate.min.js:2:552
    Loading failed for the <script> with source “https://inkgesteldwebtest.co.za/wp-content/plugins/wp-agora-io/public/js/agora/AgoraRTCSDK-3.0.2.121.js”. test:304:1
    ReferenceError: AgoraRTC is not defined
    agora-communication-client.js:5:19
    <anonymous> https://inkgesteldwebtest.co.za/wp-content/plugins/wp-agora-io/public/js/agora-communication-client.js:5
    ReferenceError: AgoraRTC is not defined
    agora-communication-client.js:5:19
    Width: 1064 communication-ui.js:156:13
    newHeight: 602.2641509433962 communication-ui.js:162:13
    TypeError: window.AGORA_COMMUNICATION_CLIENT is undefined
    test:469:7

    Plugin Contributor hermesf

    (@hermesf)

    @louisferr, Apologies but I didn’t have the latest Agora SDK properly setup with the SVN. I pushed an update to the development branch. I double checked, the AgoraSDK should be included. I will wait to confirm that your issue is resolved before pushing a new public version.

    Thank you, Got it to work, it shows the video in a corner. But thank you for the update and your work.

    Plugin Contributor hermesf

    (@hermesf)

    @louisferr @mfjunior74 I have pushed v1.5.1 publicly this should resolve the issues with the App Certificate.

    @hermesf thank you, I finally set up App ID and App Certificate and the Communication Channel works like a charm but only if the page template is Agora full, Otherwise there are visual problem (gray shape and Agora-SDK [ERROR]: – “[51156]None Ice Candidate not allowed”)

    I still have problem with Broadcast, the Broadcaster User can see the video only if the page page template is Agora full and can’t share the screen and get the error “getDisplayMedia must be called from a user gesture handler”, and the page for users that watch the streaming has some css problem (the .user_gravatar_wrapper overlay the button “Watch the Live Stream”)

    I will make more test if is a conflict from other plugin. Thank you, Marco

    Plugin Contributor hermesf

    (@hermesf)

    @mfjunior74 it sounds like there may be some conflicts with your specific installation. Please join the Agora Community Slack and we can discuss in a more real-time env.

    I’ve found that the issue with this plugin is when we save settings, Plugin overwrite other values and make them blank. So I did a quick test, I’ve applied the below code to the functions.php

    update_option( 'wp-agora-io', [
         'appId' => 'YOUR-APP-ID',
         'appCertificate' => 'YOUR-APP-CERT',
         'customerID' => 'CUST-ID',
         'customerCertificate' => 'CUST-CERT-ID'
    ]);

    PS – Plugin version: 1.5.0

    • This reply was modified 2 years, 6 months ago by devfazil. Reason: Added - Tested on plugin version info
    Plugin Author Agora.io

    (@agoraio)

    @devfazil what version of the plugin are you testing? These issues should be resolved by version 1.5.2

Viewing 13 replies - 16 through 28 (of 28 total)
  • The topic ‘Must be Something Wrong’ is closed to new replies.