Support » Theme: Museum Core » museum-core: Main Navigation Menu not working on Mobile

  • I’m using the museum-core theme for my blog, and I noticed that when viewing the page on a mobile, or when the browser width gets small, the menu does not expand when clicked. The responsive element works, as the menu changes to the 3 lines, but when I click, it does not expand. The site is using the Main Navigation menu. If I change it to use the Top-Header Navigation, the menu works as expected on a mobile. I’d much prefer to keep the menu where it currently is though. Any ideas on how I can get this to work?

    Thanks!
    Scott

    The Collection

Viewing 9 replies - 1 through 9 (of 9 total)
  • Theme Author Chris Reynolds

    (@jazzs3quence)

    I will look at it, though I’m fairly sure only the top nav menu collapses (because it would cause weird issues if you had two nav menus and both of them collapsed).

    ibes09

    (@ibes09)

    Hello! I am looking forward to use this theme, but i also have a problem with the navigation not working on mobile devices. Is there already any solution? Greetings, ibes

    Theme Author Chris Reynolds

    (@jazzs3quence)

    Top nav is the only one that works on mobile. Twitter Bootstrap has no way of handling multiple responsive nav bars.

    ibes09

    (@ibes09)

    Thank you for the fast response.
    I dont need multiple responsive nav bars, one would be enough. But I want to use the Main Navigation instead of the Top Navigation. Is there no way to use it on mobile devices, perhabs only if Top Nav is not used?
    Thanks, ibes

    Theme Author Chris Reynolds

    (@jazzs3quence)

    I’ll see what I can come up with.

    Theme Author Chris Reynolds

    (@jazzs3quence)

    Created a ticket so you can track this issue: https://github.com/jazzsequence/museum-core/issues/72

    ibes09

    (@ibes09)

    Thank you! 🙂

    Theme Author Chris Reynolds

    (@jazzs3quence)

    Just submitted an update for version 2.1.1 that will resolve this issue for both of you.

    ibes09

    (@ibes09)

    I’ll try it, thank you very much!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘museum-core: Main Navigation Menu not working on Mobile’ is closed to new replies.